PDA

View Full Version : Is Qt 4.4.0 compatible with the current MinGW 5.1.4 release?



BernieW
16th July 2008, 15:47
I already have MinGW 5.1.4 installed on my system, I downloaded the Open Source version of Qt 4.4.0 and during the install, and I receive the following message:

There is a problem with your MinGW installation:
The installer could not find a valid C:\MinGW\include\w32api.h
(The supported version is 3.2)
Do you still want to continue? (Your installation may not work)

Is anyone using Qt with the current release of MinGW if so are there any problems?

triperzonak
16th July 2008, 16:13
I already have MinGW 5.1.4 installed on my system, I downloaded the Open Source version of Qt 4.4.0 and during the install, and I receive the following message:

There is a problem with your MinGW installation:
The installer could not find a valid C:\MinGW\include\w32api.h
(The supported version is 3.2)
Do you still want to continue? (Your installation may not work)

Is anyone using Qt with the current release of MinGW if so are there any problems?

Let Qt installer download the compatible version of mingGW for you.. Dont use 5.1.4 cause like what it says "The supported version is 3.2"..

BernieW
17th July 2008, 14:55
I use an MySQL api wrapper called MYSql++ and it requires at least MinGW 3.4.5
as older versions do not work with mysql++.

SunnySan
31st July 2008, 14:04
I have installed QT4.4 + MinGW 5.1.4
and I ignore the message during the QT installation for MinGW 3.2

My projects are all compiling and running nicely under the command prompt (not as good under eclipse but this is another matter)

BernieW
1st August 2008, 00:16
I have installed QT4.4 + MinGW 5.1.4
and I ignore the message during the QT installation for MinGW 3.2

My projects are all compiling and running nicely under the command prompt (not as good under eclipse but this is another matter)


Thank you for the info.