PDA

View Full Version : qt+static (WARNING: ..phonon backend plugin could not be loaded )



solook
12th January 2012, 20:35
hi..

i compiled qt source with this code :

./configure -static -opensource -phonon -phonon-backend -qt-gif -iconv -nomake demos -nomake examples
make
make install

,,,
al thing is good but this error :
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded

and my program cant play

wysota
12th January 2012, 21:09
Applications compiled statically can't load plugins.

solook
13th January 2012, 06:55
so ..how can i use this plugins.
i copied phonon-backend dir into my program dir ... but don't word..

wysota
13th January 2012, 07:19
You can't use plugins with Qt built statically. Use dynamic linking. By the way, Phonon is licenced under LGPL which is probably why there are no static plugins for Phonon backends.

solook
13th January 2012, 08:46
is there any idea to play with Qt built statically

wysota
13th January 2012, 11:06
Use an external player or maybe see if QtMultimedia backends can be built statically.

solook
13th January 2012, 13:06
thanks..

i want to use external player..

how can i get defult player on system?

wysota
13th January 2012, 13:45
You can't.