+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

Thread: Runtime problem in Release mode

  1. #21
    Join Date
    Aug 2008
    Location
    Algarve, Portugal
    Posts
    269
    Thanks
    21
    Thanked 28 Times in 24 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60

    Default Re: Runtime problem in Release mode

    Well I got this working now

    1) Make sure you have the path system with this

    c:\qt\2009.05\qt\bin;c:\Qt\2009.05\bin

    respect the order this is important

    2) check your "windows\system32" dir and see if there is any
    qt dll's like qtcore4.dll, qtcore4d.dll qtgui.dll qtopengl.dll., etc

    if there are, and if you know that you dont have any program that will need them,
    just deleted them, if not update them with the dll's from c:\qt\2009.05\qt\bin.
    This should work.

    The problem is that if you have the correct path, it will still crash because it will
    look first in the windows system for the librarys.

    And if you update the windows system with qtcore4.dll it will still crash because will
    use the wrong qtgui.dll and others altought (and this is the nasty part to debug) the error message will still be related with qtcore4.dll.

    So in windows\system32 you have to update all of them, or delete all of them.
    _______________________________________________
    Math Graphica - scientific calculator with graphs 2D / 3D / 4D, user defined functions, system of equations, formulas and integrals
    Qt Ambassador

  2. The following user says thank you to john_god for this useful post:

    Santosh Reddy (17th March 2011)

  3. #22
    Join Date
    Dec 2010
    Posts
    1
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: Runtime problem in Release mode

    This problem may be solved but I still found it diffcult to grasp the solution initially as I had no idea about system Variable. I use Win 7 x64 and the solution that work for me was editting the 'Path' variable in the 'System Variables' section of 'Environmental Variables'. This is very important to getting a working solution. If you modify the 'User Variables' this typically will not solve your problem because this issue is caused by other programs installed on your PC contain a version of Qtcore4.dll. So simple select 'Path' from your 'System Variables' and select edit. Now at the very start of all of the variables that exist add the path to Qt. For me the path's were 'C:\Qt\2010.05\qt\bin;C:\Qt\2010.05\bin'

    Hope this helps as Qt is working perfectly for me now.

    Troy

  4. #23
    Join Date
    Feb 2013
    Posts
    2
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Runtime problem in Release mode

    still i am getting same error "exited with code -1073741511"
    my system configuration is
    windows 7, 32 bit
    qt 2010.04
    opencv2.4.3
    please help me to sort it out

  5. #24
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    31,638
    Thanks
    3
    Thanked 4,745 Times in 4,544 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Blog Entries
    4
    Wiki edits
    10

    Default Re: Runtime problem in Release mode

    What did you already try to fix your problem?
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


+ Reply to Thread

Similar Threads

  1. problem with mouse release on the border, help me!
    By dungsivn in forum Qt Programming
    Replies: 1
    Last Post: 25th June 2007, 09:16
  2. qodbc driver not loaded error in release mode
    By mandal in forum Qt Programming
    Replies: 1
    Last Post: 14th November 2006, 10:42
  3. Problem with Debug mode in KDevelop
    By zlatko in forum KDE Forum
    Replies: 1
    Last Post: 16th June 2006, 10:10
  4. Problem with Release version
    By jlbrd in forum Installation and Deployment
    Replies: 7
    Last Post: 30th March 2006, 20:45
  5. Runtime dynamic linking + Qt4 problem
    By _Ramirez_ in forum Qt Programming
    Replies: 5
    Last Post: 11th February 2006, 15:28

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts