+ Reply to Thread
Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37

Thread: Qwt-6.0.0-rc1

  1. #21
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by mariposa View Post
    No, the headers are always in "/usr/local/qwt-6.0.0-rc1/include", even if lib_bundle is set.
    Ok then I need to remove the install directive for the headers in src.pro in case of qt_framework.

    Quote Originally Posted by mariposa View Post
    I added the line "QMAKE_FRAMEWORKPATH *= $${QWT_INSTALL_PREFIX}" to the qwt.prf but the very same error (framework not found) persists. But this should not be unusual since at compile time, the framework is not yet installed in $${QWT_INSTALL_PREFIX}.
    qwt.prf is for building your application after qwt has been installed. So my question was about what happens, when you have changed qwt.prf + built and installed everything and then you try to build your application with "CONFIG += qwt".

    About building qwt: I thought you could build designer plugin and examples successfully when "CONFIG += lib_bundle" was added without any further changes ?

    If not the local directory of the framework ( in the build directory ) needs to be added to QMAKE_FRAMEWORKPATH in the project files used for building qwt. Please try this.

    Uwe

  2. #22
    Join Date
    Sep 2010
    Posts
    35
    Thanks
    5
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by Uwe View Post
    qwt.prf is for building your application after qwt has been installed. So my question was about what happens, when you have changed qwt.prf + built and installed everything and then you try to build your application with "CONFIG += qwt".
    Ah, sorry for the misunderstanding. I tried it, and the linking aborts with "ld: symbol(s) not found" (the messages before this "last" error message are referring to the unknown qwt-class symbols, I think pasting them doesn't make much sense)

    Quote Originally Posted by Uwe View Post
    About building qwt: I thought you could build designer plugin and examples successfully when "CONFIG += lib_bundle" was added without any further changes ?
    No, this only works if I move the framework-folder manually to "/Library/Frameworks". I have not yet managed to make the compiler "automatically" look in "/usr/local/qwt-6.0.0-rc1/".

    Quote Originally Posted by Uwe View Post
    If not the local directory of the framework ( in the build directory ) needs to be added to QMAKE_FRAMEWORKPATH in the project files used for building qwt. Please try this.
    I already had tried all variants of directories (including the one in the build directory), without success.

  3. #23
    Join Date
    Mar 2010
    Posts
    77
    Thanks
    17
    Thanked 1 Time in 1 Post
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Thanks for your reply, gedrite!
    I will try a bit more in a few days and if I fail I will start a new thread listing all my attempts... or perhaps just switch to Linux where I have got it all to work before. =)
    Anyway, thanks!

    Cheers!
    /Tottish

  4. #24
    Join Date
    Jul 2010
    Posts
    12
    Thanks
    2
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11

    Default Re: Qwt-6.0.0-rc1

    Hi Uwe,

    I have been using version 6.0 off the developers svn trunk for a while now and using the qwt.prf/qwtconfig.prf method of install and configuring and it is working fine for me.

    tim

  5. #25
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by mariposa View Post
    Ah, sorry for the misunderstanding. I tried it, and the linking aborts with "ld: symbol(s) not found" (the messages before this "last" error message are referring to the unknown qwt-class symbols, I think pasting them doesn't make much sense)
    Ah sorry I read the wrong piece of code in qtAddLibrary. After looking around in other qmake files I would guess the -F option is what we are looking for. So f.e in designer.pro:

    Qt Code:
    1. LIBS += -F$${QWT_ROOT}/lib
    2. qtAddLibrary(qwt)
    To copy to clipboard, switch view to plain text mode 

    If this doesn't work please check the man page of ld, what the right option is to add a path to a framework.

    Uwe

  6. #26
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Hi Tim,
    Quote Originally Posted by twells5 View Post
    ... it is working fine for me.
    The problems of mariposa are specific for working with frameworks on the Mac. What environment are you using ?

    Uwe

  7. #27
    Join Date
    Sep 2010
    Posts
    35
    Thanks
    5
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by Uwe View Post
    Ah sorry I read the wrong piece of code in qtAddLibrary. After looking around in other qmake files I would guess the -F option is what we are looking for. So f.e in designer.pro:

    Qt Code:
    1. LIBS += -F$${QWT_ROOT}/lib
    2. qtAddLibrary(qwt)
    To copy to clipboard, switch view to plain text mode 
    Yes, that worked. I changed the "LIBS"-lines for the examples and designer-plugin as indicated in your post, and it compiled fine

  8. #28
    Join Date
    Oct 2010
    Posts
    12
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by Tottish View Post
    Thanks for your reply, gedrite!
    I will try a bit more in a few days and if I fail I will start a new thread listing all my attempts... or perhaps just switch to Linux where I have got it all to work before. =)
    Anyway, thanks!

    Cheers!
    /Tottish
    See the bottome two sections on this page: http://doc.qt.nokia.com/qtcreator-2....g-plugins.html

    It clearly explains the msvc/mingw & QtCreator/plugin requirements.
    Last edited by gedrite; 14th October 2010 at 03:02.

  9. #29
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by mariposa View Post
    Yes, that worked. I changed the "LIBS"-lines for the examples and designer-plugin as indicated in your post, and it compiled fine
    I have updated the qmake project files according to what we have learned.

    Please check SVN trunk if everything compiles and installs ( headers should be installed inside the framework only ) without any manual interfering. If successful please try to use "CONFIG += qwt" and check if this is working too.

    Uwe

  10. #30
    Join Date
    Sep 2010
    Posts
    35
    Thanks
    5
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by Uwe View Post
    Please check SVN trunk if everything compiles and installs ( headers should be installed inside the framework only ) without any manual interfering. If successful please try to use "CONFIG += qwt" and check if this is working too.
    I really would like to report something better, but there are some issues left:

    1.) On the mac, there is still only the debug library being built by default. For testing purposes I changed that, of course.

    2.) The designer plugin links fine, but this does not apply to the examples. I had to change the "-L" option in line 20 of examples.pri to the "-F" option to make it work. After that everything compiled and installed fine.

    3.) Unfortunately, now there aren't any header files installed at all. Only one header file is present in the framework directory. I have a screenshot of all contents of "/usr/local/qwt-6.0.0-svn/":

    folder.png

    Therefore I didn't test compiling my application against the library, because (as far as I know) this won't work without header files.

  11. #31
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by mariposa View Post
    I really would like to report something better, but there are some issues left:
    Writing project files for a system I don't have is somehow cumbersome - anyway some day we will have a solution.

    Quote Originally Posted by mariposa View Post
    1.) On the mac, there is still only the debug library being built by default.
    In SVN debug is always enabled, but the script, that builds packages from SVN branches modifies the pri files. This was buggy for rc1, but in this situation it is o.k.

    Quote Originally Posted by mariposa View Post
    2.) The designer plugin links fine, but this does not apply to the examples. I had to change the "-L" option in line 20 of examples.pri to the "-F" option to make it work.
    Indeed I forgot to fix the project file of the designer + made several other mistakes.

    Quote Originally Posted by mariposa View Post
    3.) Unfortunately, now there aren't any header files installed at all. Only one header file is present in the framework directory. I have a screenshot of all contents of "/usr/local/qwt-6.0.0-svn/":.
    Of course the one header is also false ...

    Concerning the missing headers in the framework directory I guess when removing headers from INSTALL the behaviour of lib_bundle is affected. I hope explicitely setting QMAKE_BUNDLE_DATA will solve this problem ( the code that had no effect in your test before ).

    Please check the updated SVN trunk.

    Uwe

  12. #32
    Join Date
    Sep 2010
    Posts
    35
    Thanks
    5
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by Uwe View Post
    In SVN debug is always enabled, but the script, that builds packages from SVN branches modifies the pri files. This was buggy for rc1, but in this situation it is o.k.
    Ah, okay

    Quote Originally Posted by Uwe View Post
    Please check the updated SVN trunk.
    I checked, and it worked. It compiled at once, and all header files are at the right place. No errors during the compilation of the examples and designer plugin.

    I wanted to compile my application using "CONFIG += qwt", but I always got errors about missing headers, so obviously the qwt.prf file was not found by qmake. I checked the link that you posted some time ago (on how to make qmake know where the .prf file is), but setting "QMAKEFEATURES = /usr/local/qwt-6.0.0-svn/features" in my project file did not help. I therefore just loaded the file using "load(/usr/local/qwt-6.0.0-svn/features/qwt.prf)" and omitted the "CONFIG += qwt" line. This worked.

  13. #33
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by mariposa View Post
    I checked, and it worked. It compiled at once, and all header files are at the right place. No errors during the compilation of the examples and designer plugin.
    Please one more check: is everything okay, when you build Qwt for debug and release ?

    Qt Code:
    1. CONFIG += debug_and_release
    2. CONFIG += build_all
    To copy to clipboard, switch view to plain text mode 

    I wanted to compile my application using "CONFIG += qwt", but I always got errors about missing headers, so obviously the qwt.prf file was not found by qmake. I checked the link that you posted some time ago (on how to make qmake know where the .prf file is), but setting "QMAKEFEATURES = /usr/local/qwt-6.0.0-svn/features" in my project file did not help.
    This is a environment variable, so do "export QMAKEFEATURES = /usr/local/qwt-6.0.0-svn/features" in the shell ( assuming it is a bash ), where you execute qmake.

    Or if you want to have it permanently you can set it as qmake property: "qmake -set QMAKEFEATURES /usr/local/qwt-6.0.0-svn/features".

    Uwe

  14. #34
    Join Date
    Sep 2010
    Posts
    35
    Thanks
    5
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by Uwe View Post
    Please one more check: is everything okay, when you build Qwt for debug and release ?
    I checked, everything works fine.

    Quote Originally Posted by Uwe View Post
    This is a environment variable, so do "export QMAKEFEATURES = /usr/local/qwt-6.0.0-svn/features" in the shell ( assuming it is a bash ), where you execute qmake.

    Or if you want to have it permanently you can set it as qmake property: "qmake -set QMAKEFEATURES /usr/local/qwt-6.0.0-svn/features".
    Ah, many thanks, now it works using the "CONFIG += qwt" option

  15. #35
    Join Date
    May 2011
    Posts
    8
    Qt products
    Qt4

    Default Re: Qwt-6.0.0-rc1

    Hello,

    I installed qwt library and all the examples are built without problems.
    However when I create a project I can't use Qwt.

    I tried:
    export QMAKEFEATURES = /usr/local/qwt-6.0.0/features
    qmake -set QMAKEFEATURES /usr/local/qwt-6.0.0/features

    The qwt.prf file is in the specified directory.

    But when Im building the project I still get the error:
    /home/mribeiro/Qt_Projects/QwtTest/qwttest: error while loading shared libraries: libqwt.so.6: cannot open shared object file: No such file or directory
    /home/mribeiro/Qt_Projects/QwtTest/qwttest exited with code 127
    The contens of .pro file are:
    Qt Code:
    1. TARGET = qwttest
    2.  
    3. SOURCES += main.cpp \
    4. mainwindow.cpp \
    5. plot.cpp \
    6. curvedata.cpp \
    7. signaldata.cpp
    8. HEADERS += mainwindow.h \
    9. plot.h \
    10. curvedata.h \
    11. signaldata.h
    12.  
    13. CONFIG += qwt
    To copy to clipboard, switch view to plain text mode 

    What am I doing wrong?

    [Im using Ubuntu 10.04]
    Last edited by msr; 25th May 2011 at 02:30.

  16. #36
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    2,527
    Thanked 664 Times in 620 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Qwt-6.0.0-rc1

    Quote Originally Posted by msr View Post
    But when Im building the project I still get the error: ...
    No you already have built your application successfully - these are error messages of the loader !

    See LD_LIBRARY_PATH, ldd, ldconfig and friends.

    Uwe

  17. #37
    Join Date
    May 2011
    Posts
    8
    Qt products
    Qt4

    Default Re: Qwt-6.0.0-rc1

    Thanks for your response.

    I tried the following:
    export LD_LIBRARY_PATH=/usr/local/qwt-6.0.0/lib/
    Edit file /etc/ld.so.conf and include "/usr/local/qwt-6.0.0/lib/"
    Run ldconfig
    Run ldconfig -n "/usr/local/qwt-6.0.0/lib"
    None of them worked.

    Any suggestions?

    Im also reading http://tldp.org/HOWTO/Program-Librar...libraries.html and I think Im doing the right thing but it still doesn't work...

    Qt Code:
    1. mribeiro@mribeiro-linux:/usr/local/lib/qwt-6.0.0/lib$ ls
    2. libqwtmathml.so libqwtmathml.so.6.0 libqwt.so libqwt.so.6.0
    3. libqwtmathml.so.6 libqwtmathml.so.6.0.0 libqwt.so.6 libqwt.so.6.0.0
    To copy to clipboard, switch view to plain text mode 

    Edit1:
    Well, I copy-pasted libqwt.so.6 to /usr/lib and now it works. However I wonder how can I configure loader to search libraries in other directories. Any help is greatly appreciated!

    Edit2: Done! For further reference: create a file "*.conf" (f.e., qwt.conf) in "/etc/ld.so.conf.d/" and add path "/usr/local/qwt-6.0.0/lib"
    Last edited by msr; 26th May 2011 at 00:24.

+ Reply to Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts