+ Reply to Thread
Results 1 to 3 of 3

Thread: Mingw included in Qt installator including old .h files?

  1. #1
    Join Date
    Jun 2011
    Location
    Porto Alegre, Brazil
    Posts
    442
    Thanks
    148
    Thanked 1 Time in 1 Post
    Qt products
    Qt5
    Platforms
    Unix/X11 Windows

    Default Mingw included in Qt installator including old .h files?

    Hello!

    I'm trying to use the Windows API function "QueryFullProcessImageName" that, in accordance to its manual in Windows MSDN, is present since Windows Vista and should be declared in winbase.h.

    Now the problem is that the winbase.h that Mingw considers when building my softwares in Qt/QtCreator seems to be quite old, for it doesn't include QueryFullProcessImageName as parts of its functions.

    So my questions are:

    1º: is my interpretation correct? Does the Mingw include .h files that comes with the installation of QtCreator are old?
    2º: how can I solve this problem? I already updated my Qt Creator and Sources and the problem persists.


    Thanks,

    Momergil

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    31,030
    Thanks
    3
    Thanked 4,654 Times in 4,457 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Blog Entries
    4
    Wiki edits
    10

    Default Re: Mingw included in Qt installator including old .h files?

    You have to define which version of the API you want to use prior to including winapi files. In doubt consult MinGW docs or ask at a MinGW forum.
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  3. #3
    Join Date
    Jun 2011
    Location
    Porto Alegre, Brazil
    Posts
    442
    Thanks
    148
    Thanked 1 Time in 1 Post
    Qt products
    Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Mingw included in Qt installator including old .h files?

    Quote Originally Posted by wysota View Post
    You have to define which version of the API you want to use prior to including winapi files. In doubt consult MinGW docs or ask at a MinGW forum.
    You mean

    Qt Code:
    1. #define WINVER 0x0500
    2. #define _WIN32_WINNT 0x0600
    3.  
    4. #include "windows.h"
    5. #include <psapi.h>
    6. #include "reason.h"
    To copy to clipboard, switch view to plain text mode 

    ? If so, I already did that. Note: when I sad the winbase.h don't include this function, I mentioned it as result of Ctrl+F searching.

    About the forums and docs, well I guess I'll do that, but isn't this still a QtCreator problem? I mean, when the installator proposes to install MingW as compiler to be used by QtCreator one would expect that Nokia/Digia would include the lastest version of the compiler, not some version with includes at least 4 years old and un-updated.

+ Reply to Thread

Similar Threads

  1. Problem with including lib files
    By metow in forum Qt Tools
    Replies: 2
    Last Post: 12th December 2009, 21:57
  2. Replies: 1
    Last Post: 6th November 2009, 21:25
  3. qmake and including files doubt
    By clinisbut in forum Newbie
    Replies: 3
    Last Post: 16th August 2008, 15:40
  4. header files not getting included
    By nimmyj in forum Installation and Deployment
    Replies: 1
    Last Post: 19th December 2006, 06:18
  5. Replies: 5
    Last Post: 22nd September 2006, 08:04

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts