+ Reply to Thread
Results 1 to 2 of 2

Thread: What is my compatibility issue here?

  1. #1
    Join Date
    Apr 2017
    Posts
    20
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default What is my compatibility issue here?

    I get a compiler error when trying to create a project with a .ui file I created in designer.

    the error is "This file was generated using the moc from 4.6.4 lt"
    "cannot be used with the include files from this version of QT"
    "The moc has changed too much"

    My software versions are as follows:
    RHEL 6.7
    QT 4.8.4
    Qt Creator 3.0.1 GCC 4.4.7
    QT Designer 4.6.2
    QWT 6.1.3

    Any help would be appreciated.

    EMP

  2. #2
    Join Date
    Jul 2008
    Posts
    307
    Thanks
    9
    Thanked 38 Times in 36 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: What is my compatibility issue here?

    Hi, there seem to be two versions of Qt (4.6.4 and 4.8.4), and they are mixed up during the build process. The moc is taken from Qt 4.6.4, and compilation seems to use another Qt.

    Ginsengelf

+ Reply to Thread

Similar Threads

  1. Issue with compatibility with X11R6 (Quartz) libs
    By Caius AĆ©robus in forum Installation and Deployment
    Replies: 2
    Last Post: 16th October 2014, 11:16
  2. Replies: 4
    Last Post: 12th May 2011, 10:06
  3. Qt 4.6.3 installation and compatibility issue
    By bestsword in forum Installation and Deployment
    Replies: 0
    Last Post: 26th August 2010, 23:03
  4. VTK and QT compatibility
    By nasty81 in forum Qt Programming
    Replies: 1
    Last Post: 11th April 2008, 12:32
  5. Qtopia 4 and Zaurus (Qtopia 1.5) compatibility issue
    By alexandr in forum Qt for Embedded and Mobile
    Replies: 1
    Last Post: 4th March 2006, 21:34

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts