+ Reply to Thread
Results 1 to 1 of 1

Thread: Qt 5.9.2 WebEngine build fails with Visual Studio 2017

  1. #1
    Join Date
    Jun 2012
    Posts
    14
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Default Qt 5.9.2 WebEngine build fails with Visual Studio 2017

    I downloaded the Qt 5.9.2 sources and started building (Windows 8.1, Visual Studio 2017, 64-bit) and discovered that the build fails.
    Qt was configured with the following options:
    -opensource -debug-and-release -opengl desktop -nomake examples -nomake tests -confirm-license -skip qtdoc -qtnamespace %QT_NAMESPACE%
    with %QT_NAMESPACE% a script generated namespace of the form ABC_5_9_2

    First thing I had to do was add this patch: https://codereview.qt-project.org/#/c/208660/

    After a long wait I was then greeted with this link error:

    "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.11.25503\bi n\HostX64\x64\jom.exe" -f Makefile.core_module.Debug all
    link /NOLOGO /DYNAMICBASE /NXCOMPAT @C:/Qt-5.9.2-Build/qtwebengine/src/core/Debug_x64/Qt5WebEngineCored.rsp /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /DLL /SUBSYSTEM:WINDOWS /DEBUG /MACHINE:X64 /FIXED:NO /ignore:4199 /ignore:4221 /NXCOMPAT /fastfail /DYNAMICBASE:NO /time /verbose:incr /INCREMENTAL:NO /SUBSYSTEM:CONSOLE,5.02 /DELAYLOAD:cfgmgr32.dll /DELAYLOAD:powrprof.dll /DELAYLOAD:setupapi.dll /DELAYLOAD:BluetoothApis.dll /DELAYLOAD:Bthprops.cpl /DELAYLOAD:setupapi.dll /DELAYLOAD:mf.dll /DELAYLOAD:mfplat.dll /DELAYLOAD:mfreadwrite.dll /OPT:REF QMAKE_LFLAGS += /OPT:REF @C:/Qt-5.9.2-Build/qtwebengine/src/core/api/Debug_x64\qtwebenginecoreapid.lib /DEBUG /DLL /SUBSYSTEM:WINDOWS /VERSION:5.9 /MANIFEST:embed /OUT:..\..\lib\Qt5WebEngineCored.dll @C:\Users\GREGOR~1\AppData\Local\Temp\Qt5WebEngine Cored.dll.7248.0.jom
    LINK : fatal error LNK1117: syntax error in option ''
    Does anyone have an idea how to fix this ?
    Last edited by gvanvoor; 9th November 2017 at 14:13.

+ Reply to Thread

Similar Threads

  1. Replies: 1
    Last Post: 9th October 2017, 23:21
  2. Replies: 0
    Last Post: 11th September 2017, 20:21
  3. Qt 5.9 Fails to generate visual studio project
    By mentalmushroom in forum Newbie
    Replies: 0
    Last Post: 6th June 2017, 14:15
  4. Can't build qwt with visual studio
    By Patrik in forum Qwt
    Replies: 10
    Last Post: 14th April 2011, 01:56
  5. Build application using visual studio 6 ?
    By aamer4yu in forum Newbie
    Replies: 1
    Last Post: 3rd October 2006, 10:34

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts