+ Reply to Thread
Results 1 to 1 of 1

Thread: updatePaintNode broken with ANGLE/AA_UseOpenGLES ??

  1. #1
    Join Date
    Aug 2013
    Posts
    2
    Qt products
    Qt5
    Platforms
    Windows

    Default updatePaintNode broken with ANGLE/AA_UseOpenGLES ??

    I've been trying to create my own custom QQuickItem using updatePaintNode for the rendering, I've used an example as a base for testing and it seems that using ANGLE for rendering completely breaks it and results in a blank window. Is this a bug or am I missing something here?

    An example project is attached and was originally compiled/tested under Qt 5.10. It's currently setup in main.cpp to use "AA_UseOpenGLES" which causes the clock to not show, comment that out and use AA_UseDesktopOpenGL and it will show up fine.

    Any help would be greatly appreciated.


    EDIT:

    Ignore, fixed it by changing
    setDrawingMode(GL_POLYGON);

    to

    setDrawingMode(QSGGeometry:rawTriangleFan);
    Attached Files Attached Files
    Last edited by twisted89; 9th May 2018 at 16:46.

+ Reply to Thread

Similar Threads

  1. Replies: 1
    Last Post: 12th January 2016, 14:16
  2. qt opengl es angle and configuration
    By giugio in forum Newbie
    Replies: 5
    Last Post: 23rd August 2013, 05:43
  3. Draw angle indicator QPainter
    By iPick12 in forum Qt Programming
    Replies: 1
    Last Post: 26th October 2012, 14:27
  4. Replies: 0
    Last Post: 29th March 2011, 17:54
  5. Qt4.3 broken by Qt4.4
    By bnilsson in forum Installation and Deployment
    Replies: 2
    Last Post: 4th January 2008, 11:41

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts