PDA

View Full Version : Cannot mix incompatible Qt libraries



learning_qt
16th September 2009, 14:42
My application depends on those two qt packages
libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x400d9000)
libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x40d65000)

and I checked from my computer, I found those installed Qt packages
libqt4-core install
libqt4-dbus install
libqt4-sql install
libqt4-sql-sqlite install
libqt4-test install
libqt4-xml install
libqtcore4 install
libqtgui4 install

what caused this problem?

faldzip
16th September 2009, 16:56
But what is the problem? Is your application not working? I think that libqt4-core is just a transitional package so in my opinion it is just installing libqtcore4 (or something like this).

learning_qt
17th September 2009, 08:59
The problem was resolved and I used the different versions.

Thanks!