PDA

View Full Version : phonon does not work on Qt 4.5.3,what is the problem?



mismael85
16th December 2009, 16:52
hello all;
I am trying to operate sound file. first i used Qt4.5.0 and my application runs very well on it
but the target device have Qt4.5.3 when i tried to operate my application on it i get the following message.



WARNING: Phonon needs QCoreApplication::applicationName to be set to export audio output names through the DBUS interface
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: Phonon::createPath: Cannot connect Phonon::MediaObject ( no objectName ) to Phonon::AudioOutput ( no objectName ).
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
note : the program runs but the sound does not
i am using linux ubuntu 9.4 in the both devices.
where is the problem?

high_flyer
17th December 2009, 10:34
the warning says that the back end plugihn could not be loaded.
Read the Phonon requirements, in the documentation, and make sure that Qt is configured with phonon, and that the required back ends are installed on your system.

mismael85
17th December 2009, 12:07
how can i check my qt configuration?
on the device which have Qt4.5.0 the libphonon_gstreamer.so is installed in the directory
/usr/lib/kde4/plugins/phonon-backend/
but on the device having Qt4.5.3 the libphonon_gstreamer.so does not exist

high_flyer
21st December 2009, 12:03
use ./configure to configure your Qt installation.