PDA

View Full Version : Custom Widgets



walden02
22nd December 2009, 12:13
I created several custom widgets for QT 4.2.3 integrated with Visual Studio 2005.

I could use widgets in QT designer as well as VS 2K5

Just upgraded to QT 4.5.0 - still using VS 2K5
Now I get this error for each of my custom widgets:
The plugin 'C:/Program Files/Nokia/Qt VS Integration/plugins/designer/RS_DualQlistWidget.dll' uses incompatible Qt library. (4.5.0) [release]

If I use QT Creator, I get a bunch of link errors (and am not sure how to resolve them).

I want to use QT 4.5.0 + VS 2K5 with my custom widgets...

Any Thoughts?

high_flyer
22nd December 2009, 12:47
Did you try to rebuild your plugins with Qt4.5.0?

walden02
22nd December 2009, 20:00
Sorry - yes I did.

In fact:
1) I removed all files from the project except Source code + Header Files and *.pro file.
2) Ran qmake on pro file to generate a vcproj file.
3) Compiled against QT 4.5.0

Widgets show up in Designer just fine...
Widgets do not get loaded in VS 2k5 QT toolbox - error message is displayed

high_flyer
23rd December 2009, 12:43
Do you have both Qt versions still installed on your system?
It could be that MSVS is still getting the old version designer.
Make sure the system variables are set correctly (QTDIR)