PDA

View Full Version : I Think that qsqlpsqld4 is corrupt



Aureon
18th January 2010, 12:49
Hi!! Good morning!!

First, thanks for attend me. And sorry for my bad english.

I try to modify the code of the demo: sqlbrowser in qy 4.6.0.0. I download the binaries, and the precompiled version for qt 4.6 with all libraries also compiled. I created the project to VS2008, i compiled them, and I get the following linker problem when need a precompiled library of sql plugins (PostgreSQL):


'sqlbrowser.exe': se cargó 'P:\Programas\Qt_4.6\plugins\sqldrivers\qsqlpsqld4 .dll'
LDR: LdrpWalkImportDescriptor() failed to probe P:\Programas\Qt_4.6\plugins\sqldrivers\qsqlpsqld4. dll for its manifest, ntstatus 0xc0150002
'sqlbrowser.exe': se descargó 'P:\Programas\Qt_4.6\plugins\sqldrivers\qsqlpsqld4 .dll'


I tried to add a direct reference to the dll with Visual Studio 2008 (qsqlpsqld4.dll) but it tells me is corrupt and can not be read (in compilation).

I assume that is corrupted, but I have not generated, the source is precompiled, and I download it.

The solution: recompile the library PLSQL??? What is your opinion???

Thank you very much for your attention.

Aureon

Aureon
19th January 2010, 10:33
The precompiled version of the plugin library is corrupt, or not funcional.

Solution: recompile the library, and use this manual for run the aplications: http://qtwiki.org/QPSQL_driver_not_loaded_-_unusual_solution

Thanks a lot!

wysota
19th January 2010, 11:37
It's probably not corrupt but rather prebuilt for MinGW and not Visual Studio.