PDA

View Full Version : How to install Qt 5.0.0 on OpenSuse 11.4



8Observer8
15th January 2013, 12:20
Hi everyone!

How to install Qt 5.0.0 on OpenSuse 11.4?

I wrote this command:


./qt-linux-opensource-5.0.0-x86-offline.run

But:

./qt-linux-opensource-5.0.0-x86-offline.run: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./qt-linux-opensource-5.0.0-x86-offline.run)

Thank you

Ivan

agarny
15th January 2013, 15:42
You seem to be missing some C++ libraries. Make sure that you have a full C++ toolchain.

8Observer8
15th January 2013, 16:01
agarny, help me!

How to install the 'C++ library'. I'm new in the Linux OpenSuse 11.4

agarny
15th January 2013, 16:06
I don't personally use OpenSUSE, but a very simple google search would have given you the answer, e.g. http://www.unixmen.com/install-development-environment-on-opensuse/.

8Observer8
15th January 2013, 16:37
Thank you very much :D

Added after 22 minutes:

Output:



Ivan@linux-cudn:~> sudo zypper install -t pattern devel_C_C++
root's password:
Loading repository data...
Warning: Repository 'Updates for openSUSE 11.4 11.4-0' appears to outdated. Consider using a different mirror or server.
Reading installed packages...
'pattern:devel_C_C++' is already installed.
No update candidate for 'devel_C_C++-11.4-6.9.1.i586'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.
Ivan@linux-cudn:~>


:(

Viper666
15th January 2013, 16:50
have you use chmod before ./qt-... ?

8Observer8
15th January 2013, 16:54
Yes



-rwx--x--x 1 Ivan users 430605254 Jan 15 01:01 qt-linux-opensource-5.0.0-x86-off

agarny
15th January 2013, 16:57
Thank you very much :D

Added after 22 minutes:

Output:



Ivan@linux-cudn:~> sudo zypper install -t pattern devel_C_C++
root's password:
Loading repository data...
Warning: Repository 'Updates for openSUSE 11.4 11.4-0' appears to outdated. Consider using a different mirror or server.
Reading installed packages...
'pattern:devel_C_C++' is already installed.
No update candidate for 'devel_C_C++-11.4-6.9.1.i586'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.
Ivan@linux-cudn:~>


:(

As you can see from the output of the command, your repository appears to be outdated (line 4), so maybe you probably need to do something about it. From line 7, it would seem that you are all set for C/C++ development, but the version of the toolchain you have on your system is, apparently, not recent enough for Qt.

8Observer8
15th January 2013, 17:03
How to update the 'devel_C_C++' from the command?

agarny
15th January 2013, 17:06
As I said, I don't personally use OpenSUSE and this is a forum for Qt-related issues, so assuming my assessment of your problem is correct, I would suggest you try some OpenSUSE forum...

8Observer8
15th January 2013, 17:12
Ok. You helped me. I understood this problem. I will write a solution here. Thanks :)