PDA

View Full Version : Qt 4.01 and Qt 4.1



Morea
14th February 2006, 23:13
Are these versions incompatible?
Can a ui file created with the 4.01 version be changed to suit the the 4.1 version?

jacek
14th February 2006, 23:17
Qt 4.1 introduces many new features as well as many improvements and
bugfixes over the 4.0.x series. For more details, see the online
documentation which is included in this distribution. The
documentation is also available at http://doc.trolltech.com/

The Qt version 4.1 series is binary compatible with the 4.0.x series.
Applications compiled for 4.0 will continue to run with 4.1.
The rest is here (http://www.trolltech.com/developer/changes/changes-4.1.0.html).

In short: yes, you can use that .ui file in Qt 4.1.

Morea
14th February 2006, 23:33
Strange I took a ui file from a windows machine and I got some errors in the linux machine. If I can reproduce the error, I'll post it.

yop
16th February 2006, 20:12
Strange I took a ui file from a windows machine and I got some errors in the linux machine. If I can reproduce the error, I'll post it.
EOLs perhaps?