PDA

View Full Version : QCustom3DVolume items are not supported with OpenGL ES2



lni
20th October 2018, 23:50
Hi,

I try to run volumetric example but got error "QCustom3DVolume items are not supported with OpenGL ES2"

I do google search but don't really get much help.

Can someone tell me if this is due hardware or software problem, and how to solve it?

Many thanks

ChrisW67
21st October 2018, 08:27
Hi,
I try to run volumetric example but got error "QCustom3DVolume items are not supported with OpenGL ES2"
I do google search but don't really get much help.

It's there, right on the documentation page for QCustom3DVolume


Note: Volumetric objects utilize 3D textures, which are not supported in OpenGL ES2 environments.



Can someone tell me if this is due hardware or software problem, and how to solve it?
It is the absence of full OpenGL support on whatever platform you are on. OpenGL ES is a subset of OpenGL suitable for portable devices. This can be a lack of hardware support or maybe a choice of driver.
What is reported by...?

glxinfo -B

lni
21st October 2018, 16:52
What is reported by...?

glxinfo -B

Thank you ChrisW67 for the reply.

How do I run glxinfo in the Windows 7 or Windows 10?

My Windows 7 has Nvidia Quadro 2000M, and the Windows 10 has Nvidia 960m. Both machine has the latest driver from Nvidia website.

lni
26th October 2018, 05:10
Anyone please?

Thanks