PDA

View Full Version : qwt designer build errors



jhearon
12th July 2007, 19:27
Win32, XP, QT open source vers.
QWT 5.0.2 with QT4.
Nmake gets stuck on building qwt designer:
Tried also using msvc project, instead of makefile, but still get unresolved external symbol errors (lots). Not sure what it's missing?


qwt_designer_plugin error LNK2001: unresolved external symbol "__declspec(dllimport) public: static struct QMetaObject const QwtDial::staticMetaObject" (__imp_?staticMetaObject@QwtDial@@2UQMetaObject@@B )
qwt_designer_plugin error LNK2001: unresolved external symbol "__declspec(dllimport) public: static struct QMetaObject const QwtPlot::staticMetaObject" (__imp_?staticMetaObject@QwtPlot@@2UQMetaObject@@B )
qwt_designer_plugin error LNK2001: unresolved external symbol "private: virtual double __thiscall QwtKnob::getValue(class QPoint const &)" (?getValue@QwtKnob@@EAENABVQPoint@@@Z)
....etc.

QT4 seems working fine, environment variables set, etc.
Have qwtconfig.pri set to install in same folder as sources.
Thank You.

jpn
12th July 2007, 20:08
Which exact version of Qt? What changes exactly were applied to qwtconfig.pri?

jhearon
13th July 2007, 18:17
qt-win-opensource-4.2.3 (msvc build)
qwt-5.0.2
WinXP pro, msvc .NET 2003
-----
changes to qwtconfig.pri:

Moved unzipped sources (Qwt-5.02 to Temp)
modified INSTALLBASE to point to local directory ex. C:/Temp/QWT-5.0.2 and install libs in source folder.

# Install paths
win32 {
INSTALLBASE = C:/Qwt-5.0.2
}
----
QWT build gets stuck on qwt designer with unresolved external symbol errors. Seems like it's not finding something it needs. Not sure what it's looking for.


Thanks.

jhearon
15th July 2007, 06:52
Also tried QWT with MSVC build of QT4.3.0. Tried QWT 5.0.1, and 5.0.2. Tried generating MSVC projects for building, and also using nmake.

Still getting unresoved external symbol errors...

qwt_designer_plugin.obj : error LNK2001: unresolved external symbol "protected:
virtual void __thiscall QwtPlot::printLegend(class QPainter *,class QRect const
&)const " (?printLegend@QwtPlot@@MBEXPAVQPainter@@ABVQRect@@ @Z)
etc.

jhearon
17th July 2007, 07:47
Switched to Vista and QWT. Still getting build errors. Using qmake and decommenting the option to build examples it claims it cannot find uuic.lib, which is located in the sdk, not in msvc.

O.K. Recommented the examples and tried again. Get the qwt4.lib, and qwt5.dll, but no examples, so tried building vcprojs of examples and pointing each project towards uuic.lib in the msvc project settings.

Works sort of, but get "file corrupt" error on qwt5.dll.

Alright then forget qwt on windows.

(Good news is, I think it's working on Linux)