PDA

View Full Version : QT-Eclipse integration error



comlink21
16th August 2007, 05:27
I install QT-Eclipse integration into my server, everything work fine unless for the QT Designer and pro file, the error message that showing is the following.

java.lang.UnsatisfiedLinkError: libqtcppdesigner: /usr/lib64/libqtcppdesigner.so: wrong ELF class: ELFCLASS32
at java.lang.Runtime._load(libgcj.so.7rh)
at java.lang.Runtime.loadLibrary(libgcj.so.7rh)
at java.lang.System.loadLibrary(libgcj.so.7rh)
at com.trolltech.qtcppdesigner.views.WidgetBoxW.<clinit>(WidgetBoxW.java:21)
at java.lang.Class.initializeClass(libgcj.so.7rh)
at com.trolltech.qtcppdesigner.views.WidgetBoxView.cr eatePartControl(WidgetBoxView.java:16)
at org.eclipse.ui.internal.ViewReference.createPartHe lper(ViewReference.java:332)
at org.eclipse.ui.internal.ViewReference.createPart(V iewReference.java:197)
at org.eclipse.ui.internal.WorkbenchPartReference.get Part(WorkbenchPartReference.java:566)
at org.eclipse.ui.internal.PartPane.setVisible(PartPa ne.java:290)
at org.eclipse.ui.internal.ViewPane.setVisible(ViewPa ne.java:525)
at org.eclipse.ui.internal.presentations.PresentableP art.setVisible(PresentablePart.java:140)
at org.eclipse.ui.internal.presentations.util.Present ablePartFolder.select(PresentablePartFolder.java:2 68)
at org.eclipse.ui.internal.presentations.util.LeftToR ightTabOrder.select(LeftToRightTabOrder.java:65)
at org.eclipse.ui.internal.presentations.util.TabbedS tackPresentation.selectPart(TabbedStackPresentatio n.java:394)
at org.eclipse.ui.internal.PartStack.refreshPresentat ionSelection(PartStack.java:1144)
at org.eclipse.ui.internal.PartStack.createControl(Pa rtStack.java:620)
at org.eclipse.ui.internal.PartStack.createControl(Pa rtStack.java:532)
at org.eclipse.ui.internal.PartSashContainer.createCo ntrol(PartSashContainer.java:562)
at org.eclipse.ui.internal.PerspectiveHelper.activate (PerspectiveHelper.java:244)
at org.eclipse.ui.internal.Perspective.onActivate(Per spective.java:815)
at org.eclipse.ui.internal.WorkbenchPage.onActivate(W orkbenchPage.java:2436)
at org.eclipse.ui.internal.WorkbenchWindow$6.run(Work benchWindow.java:2616)
at org.eclipse.swt.custom.BusyIndicator.showWhile(org .eclipse.swt.gtk.linux.x86_64_3.2.2.v3236.jar.so)
at org.eclipse.ui.internal.WorkbenchWindow.setActiveP age(WorkbenchWindow.java:2597)
at org.eclipse.ui.internal.WorkbenchWindow.restoreSta te(WorkbenchWindow.java:1982)
at org.eclipse.ui.internal.Workbench.doRestoreState(W orkbench.java:2857)
at org.eclipse.ui.internal.Workbench.access$14(Workbe nch.java:2805)
at org.eclipse.ui.internal.Workbench$19.run(Workbench .java:1681)
at org.eclipse.ui.internal.Workbench.runStartupWithPr ogress(Workbench.java:1421)
at org.eclipse.ui.internal.Workbench.restoreState(Wor kbench.java:1679)
at org.eclipse.ui.internal.Workbench.access$12(Workbe nch.java:1650)
at org.eclipse.ui.internal.Workbench$17.run(Workbench .java:1529)
at org.eclipse.core.runtime.SafeRunner.run(org.eclips e.equinox.common_3.2.0.v20060603.jar.so)
at org.eclipse.ui.internal.Workbench.restoreState(Wor kbench.java:1473)
at org.eclipse.ui.internal.WorkbenchConfigurer.restor eState(WorkbenchConfigurer.java:183)
at org.eclipse.ui.application.WorkbenchAdvisor.openWi ndows(WorkbenchAdvisor.java:702)
at org.eclipse.ui.internal.Workbench.init(Workbench.j ava:1085)
at org.eclipse.ui.internal.Workbench.runUI(Workbench. java:1847)
at org.eclipse.ui.internal.Workbench.createAndRunWork bench(Workbench.java:419)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(Pl atformUI.java:149)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDE Application.java:95)
at org.eclipse.core.internal.runtime.PlatformActivato r$1.run(org.eclipse.core.runtime_3.2.0.v20060603.j ar.so)
at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.runApplication(org.eclipse.osgi_3.2.2.R 32x_v20070118.jar.so)
at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.start(org.eclipse.osgi_3.2.2.R32x_v2007 0118.jar.so)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(org.eclipse.osgi_3.2.2.R32x_v20070118.jar.so)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(org.eclipse.osgi_3.2.2.R32x_v20070118.jar.so)
at java.lang.reflect.Method.invoke(libgcj.so.7rh)
at org.eclipse.core.launcher.Main.invokeFramework(sta rtup.jar.so)
at org.eclipse.core.launcher.Main.basicRun(startup.ja r.so)
at org.eclipse.core.launcher.Main.run(startup.jar.so)
at org.eclipse.core.launcher.Main.main(startup.jar.so )

does anyone know how to solve the problem;

thanks for help
-comlink21

jacek
17th August 2007, 00:18
/usr/lib64/libqtcppdesigner.so: wrong ELF class: ELFCLASS32
It looks like you have a 32-bit library installed instead of 64-bit one.