Results 1 to 2 of 2

Thread: Qt3 Installation on Ubuntu 7.04

  1. #1

    Default Qt3 Installation on Ubuntu 7.04

    I am trying to install qt3 version 3.3.8 from source code because a program I want to install requires Qt3. After unpacking the files I run configure and everything appears fine. When I run make the following error occurs:

    elease-shared/moc_qmotifstyle.o -L/usr/X11R6/lib -lXext -lX11 -lm -ldl
    /usr/bin/ld: cannot find -lXext
    collect2: ld returned 1 exit status
    make[2]: *** [../lib/libqt.so.3.3.8] Error 1
    make[2]: Leaving directory `/usr/local/qt/src'
    make[1]: *** [sub-src] Error 2
    make[1]: Leaving directory `/usr/local/qt'
    make: *** [init] Error 2
    I can not figure out what is wrong. I appreciate your help.
    Last edited by jpn; 16th January 2008 at 19:21. Reason: missing [quote] tags

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: Qt3 Installation on Ubuntu 7.04

    Try installing libxext-dev:
    sudo apt-get install libxext-dev
    I'd suggest you do the same with Qt 3 (install packages libqt3-* and qt3-* instead of compiling it by hand).
    J-P Nurmi

Similar Threads

  1. Unsolved ubuntu installation of qt problem
    By sincnarf in forum Installation and Deployment
    Replies: 1
    Last Post: 30th September 2007, 09:41

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.