Results 1 to 7 of 7

Thread: Newbie installation problem under XP

  1. #1
    Join Date
    Mar 2008
    Posts
    44
    Thanks
    2
    Platforms
    Unix/X11 Windows

    Default Newbie installation problem under XP

    Hi

    I am developing a toy signal processing application on my laptop. Under Linux (slackware) the application is running fine, however, my soundcard is not supported well enough. I therefore have to port the application to a windows platform (both XP and Vista are available).
    I am struggling with installing qwt in as MSYS/MinGW environment. I recompiled the whole Qt suite (well over two hours compiling), and when I install Qwt it designer complains that qwt.dll and qwt_designer_plugin are not valid plugins.http://www.qtcentre.org/forum/images/smilies/mad.png

    I recompiled everything couple of times with no other results.
    It seems to me that my operating environment is not that special so I cannot imagine to be the only one with that symptom. Most likely something very simple, but I'm lost

    best

  2. #2
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    3,316
    Thanked 879 Times in 827 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Newbie installation problem under XP

    1) First try to execute the Qwt examples ? If you are not successful, I guess you forgot to set the path to the Qwt libraries in your PATH environment.

    2) If you can execute the Qwt examples, but you can't load the designer plugin, it could be because of a debug/release mismatch between designer and Qwt library.

    Uwe

  3. #3

    Default Re: Newbie installation problem under XP

    I am having slightly different problem. I am using Dev C++ with QT on Win XP SP2, and recently have installed qwt. The compilation process goes fine - no errors, but ultimately, when running the application what I get is an initialization error (#0xc0000005). What that could mean.
    TIA,
    Best
    Urban

  4. #4
    Join Date
    Feb 2006
    Location
    Munich, Germany
    Posts
    3,316
    Thanked 879 Times in 827 Posts
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Newbie installation problem under XP

    Did you add QWT_DLL to your compile flags ?

    Uwe

  5. #5
    Join Date
    Mar 2008
    Posts
    44
    Thanks
    2
    Platforms
    Unix/X11 Windows

    Thumbs up Re: Newbie installation problem under XP

    Hi

    It worked. I spent the whole day on installing Qt/Qwt and I finally managed. Indeed problems with paths were the cause. What struck me was that
    a. installation had to be done in the Qt shell window (under MinGW), while MSYS installation did not work
    b. adding a path element to this shell required editing the file qtvars (which is generated but I cvannot find the source)
    c. running the examples required putting qwt.dll in some other libraries
    d. installing the plugin files in Qwt in the plugin directory in Qt solved the last problems

    Tomorrow I'll try to run some application, still have to link my applicartion code (originally written in Qt3.3) to portaudio as well.

    Well, it is raining anyway, so who wants to be outside

    best
    janK

  6. #6

    Default Re: Newbie installation problem under XP

    Well, I can use it with CodeBlocks and it works fine after adding QWT_DLL to compiler flags, but when it comes to Dev-Cpp changing the compiler flags doesn't help. Means, that I get still the same initialization error. I don't know why is that.

  7. #7
    Join Date
    Mar 2008
    Posts
    25
    Thanks
    1
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Newbie installation problem under XP using VS 7.0

    Hello everybody.

    Just compiled the QWT using VS7.0. The examples are executable. Tried to integrate the QWT plugin to the Designer by coping files qwt_designer_plugin5.dll, qwt_designer_plugin5.exp and qwt_designer_plugin5.lib to the "D:\libs\Qt\4.3.4\plugins\designer\" and got the problem.

    The plugin does not work. Looked through the Designer->Help->About Plugins and discovered:
    The file "D:/libs/Qt/4.3.4/plugins/designer/qwt_designer_plugin5.dll" is not a valid Qt plugin.
    it seems to me the problem is in compiling libs as the debug.
    Can you help me please how to compile release libs if the problem is there?

    Thank you,
    Ruslan
    Last edited by ru_core; 15th July 2008 at 12:22.

Similar Threads

  1. Eclipse+MinGW+QT installation Problem?
    By greenoaktree in forum Qt Programming
    Replies: 3
    Last Post: 14th January 2008, 16:08
  2. Unsolved ubuntu installation of qt problem
    By sincnarf in forum Installation and Deployment
    Replies: 1
    Last Post: 30th September 2007, 09:41
  3. Serious installation problem
    By Morea in forum Installation and Deployment
    Replies: 1
    Last Post: 19th September 2007, 10:15
  4. Qt4: Problem after installation
    By naccchii in forum Installation and Deployment
    Replies: 2
    Last Post: 5th July 2007, 11:15
  5. painter problem in new Qt-4.2.3 installation
    By impeteperry in forum Installation and Deployment
    Replies: 2
    Last Post: 2nd May 2007, 05:34

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.