Results 1 to 4 of 4

Thread: 'XEvent' has not been declared

  1. #1
    Join Date
    Jan 2008
    Posts
    7
    Thanks
    1
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Default 'XEvent' has not been declared

    I am trying to use the QX11EmbedContainer and QX11EmbedWidget classes but I get always the following error:

    /include/QtGui/qx11embed_x11.h:57: error: 'XEvent' has not been declared
    /include/QtGui/qx11embed_x11.h:95: error: 'XEvent' has not been declared
    The installation of qtopia was successful but this error refers to the header files provided by Trolltech.

    Has anyone faced the same problem or knows how to solve it?
    Last edited by jpn; 31st March 2008 at 08:43. Reason: missing [quote] tags

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: 'XEvent' has not been declared

    Wait, you are using Qtopia without X11 and XEmbed for X11...?
    J-P Nurmi

  3. #3
    Join Date
    Jan 2008
    Posts
    7
    Thanks
    1
    Qt products
    Qt3 Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Default Re: 'XEvent' has not been declared

    Wait, you are using Qtopia without X11 and XEmbed for X11...?
    Sorry but I don't understand your question. What I am trying to do is a widget that can contain (embed) other applications that run under X11. But if I declare a QX11EmbedContainer or a QX11EmbedWidget widget the output I get when I try to compile my program is that 'XEvent' has not been declared.

    Could you explain what did you meant with that question, please?

  4. #4
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: 'XEvent' has not been declared

    I was just wondering if XEmbed stuff is really available on Qtopia core which doesn't depend on X11.
    J-P Nurmi

Similar Threads

  1. Installation on Fedora Core 4
    By jcr in forum Installation and Deployment
    Replies: 3
    Last Post: 29th January 2009, 01:34
  2. Just for fun game
    By vermarajeev in forum Qt-based Software
    Replies: 6
    Last Post: 13th December 2007, 21:52
  3. Error compiling psql plugin
    By vieraci in forum Installation and Deployment
    Replies: 4
    Last Post: 7th October 2007, 02:49
  4. qt 4.2.2 install on aix
    By try to remember in forum Installation and Deployment
    Replies: 2
    Last Post: 28th March 2007, 12:19
  5. Problems
    By euthymos in forum Installation and Deployment
    Replies: 2
    Last Post: 13th June 2006, 19:11

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.