Results 1 to 3 of 3

Thread: id3lib library problem

  1. #1
    Join Date
    Feb 2006
    Posts
    12
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default id3lib library problem

    Hi everyone,
    I am having a some problems using the id3lib library.
    I have installed all id3lib libraries needed , i follow the instruction given by id3lib doc
    and on this line ID3_Tag tag("test.mp3"); gives me an error something like undifined type before string,
    I am also including the needed headers as shown in the id3lib (#include <id3/tag.h>)
    guys pls help me with this.
    thanks in advance.
    I Think therefore I Code...

  2. #2
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    6,264
    Thanks
    36
    Thanked 1,518 Times in 1,388 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Maemo/MeeGo

    Default Re: id3lib library problem

    Are you linking id3lib to your project?
    J-P Nurmi

  3. #3
    Join Date
    Feb 2006
    Posts
    12
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: id3lib library problem

    Yes I am linking it, as a shared library and it finds it correclty.
    something is wrong though and I cant figure it out. In any case thank you jpn.
    I will be using the taglib, its seems more convinient, although it had some problems too with the linking part where my ldconfig could not actually find it and cache it. anyway i fix it manually.
    thanks again.
    I Think therefore I Code...

Similar Threads

  1. plugin in a library
    By alisami in forum Qt Programming
    Replies: 2
    Last Post: 3rd October 2008, 17:21
  2. Weird problem: multithread QT app kills my linux
    By Ishark in forum Qt Programming
    Replies: 2
    Last Post: 8th August 2008, 09:12
  3. Library and Subdirs building problem
    By herenbdy in forum Qt Programming
    Replies: 2
    Last Post: 10th July 2008, 02:10
  4. so shared library problem
    By mtrpoland in forum Newbie
    Replies: 3
    Last Post: 13th August 2007, 21:51
  5. shared library problem
    By nhatkhang in forum KDE Forum
    Replies: 9
    Last Post: 28th November 2006, 04:07

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.