Results 1 to 3 of 3

Thread: Qt Creator - Delay of whole GUI

  1. #1

    Default Qt Creator - Delay of whole GUI

    Hi guys,

    i'm new to Qt but already a big fan of this library. I looked at some demonstrations and already played around with Qt Creator. However one thing kind of confuses me. While dragging control objects, using the scroll bar or just clicking somewhere in the user interface of Qt Creator I often have some delay till the desired action comes into place.
    For example I want to place a button. While hovering the mouse pointer over the corresponding entry, left clicking and dragging to the working space the "button"-symbol doesn't immediately stay in place after the left mouse button is released - it kind of gets "attached" to the mouse pointer.
    After a little while (meaning the delay) the control gets finally placed where I first released the mouse button and I can grab another one.

    Any idea?
    Last edited by @nubis; 10th August 2009 at 23:10.

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Qt Creator - Delay of whole GUI

    Please provide some more info. What OS are you using? Does it happen at every time or only sometimes? etc.
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  3. #3

    Default Re: Qt Creator - Delay of whole GUI

    I'm using windows x64, quad core, 4gb ram, geforce 8800 gtx. System drive is western digital raptor.
    I made a little video which shows the delay. Right at the beginning the pushButton doesn't stay where it should be - after releasing the mouse button.
    At the end I select the main.cpp entry. As you can see it actually gets highlighted with some delay.

    btw, that fast clicking isn't the problem. If I click that "crazy" inside the Qt creator installed on my notebook, all works fine.


    http://www.youtube.com/watch?v=y5D0YRpsyqI


    Hope that helps

Similar Threads

  1. long running paint + menu hole
    By hvw59601 in forum Qt Programming
    Replies: 1
    Last Post: 1st November 2007, 13:04

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.