Results 1 to 2 of 2

Thread: side-by-side configuration is incorrect

  1. #1

    Default side-by-side configuration is incorrect

    I am trying to run Qt (4.5.2) with static lib in debug version using
    VC 8 (2005) on Windows.

    It works fine on the very machine where it's made.
    But it gives me error messages as below when I try it on other machines.

    "The application has failed to start because the application configuration
    is incorrect. Reinstalling the application may fix this problem"

    or

    "The application has failed to start because it's side-by-side configuration
    is incorrect. Please see the application event log for more detail"


    Could you tell me what the message means?

    I searched and got similar threads
    from the web and Qt forum. I tried several but with no success.

    My code is the simplest one "Hello Qt" from the QT book.


    fyi, here are the setup for VS2005.

    C/C++:

    /I "..\..\..\QT\4.5.2\include\QtCore" /I "..\..\..\QT\4.5.2\include\QtGui"
    /I "..\..\..\QT\4.5.2\include" /I "." /I "..\..\..\QT\4.5.2\include\ActiveQt"
    /I "debug" /I "..\..\..\QT\4.5.2\mkspecs\default" /D "_WINDOWS" /D "UNICODE"
    /D "WIN32" /D "QT_LARGEFILE_SUPPORT" /D "QT_GUI_LIB" /D "QT_CORE_LIB"
    /D "QT_THREAD_SUPPORT" /FD /EHsc /MTd /GS- /Zc:wchar_t- /Fo"debug\\" /Fd".
    \\" /W3 /nologo /c /Zi /TP /errorReportrompt

    Linker:

    /OUT:"debug\2dial.exe" /NOLOGO /LIBPATH:"c:\QT\4.5.2\lib"
    /MANIFEST /MANIFESTFILE:"debug\\2dial.exe.intermediate.manife st"
    /NODEFAULTLIB:"LIBCMTD.LIB" /DEBUG /MAP /SUBSYSTEM:WINDOWS
    /ERRORREPORT:PROMPT
    c:\QT\4.5.2\lib\qtmaind.lib c:\QT\4.5.2\lib\QtGuid.lib
    c:\QT\4.5.2\lib\QtCored.lib gdi32.lib comdlg32.lib oleaut32.lib
    imm32.lib winmm.lib winspool.lib ws2_32.lib ole32.lib user32.lib
    advapi32.lib msimg32.lib shell32.lib kernel32.lib uuid.lib
    kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib
    advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib
    odbc32.lib odbccp32.lib

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: side-by-side configuration is incorrect

    It's a Windows message, it has nothing to do with Qt. It's most likely your libraries are incompatible with the system you're running them on (like if you're trying to deploy Qt libraries in Win98 environment) or you forgot to deploy Qt libs at all.

    There is of course also the question of the point of deploying application in debug static mode...
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.