Results 1 to 4 of 4

Thread: Got "the inferior stopped ..." when debug

  1. #1
    Join Date
    Jun 2009
    Posts
    74
    Thanks
    23
    Thanked 2 Times in 2 Posts

    Default Got "the inferior stopped ..." when debug

    Hi All,

    I am using QT4.6.
    when try to debug the application,even set a breakpoint at the first line of main.cpp
    I will get a popup window :

    Signal received:
    The inferior stopped because it received a signal from
    the operating system.
    signal name:sigsegv
    signal meaning: segmentation fault

    and it also show a window contain assemble codes.

    Any ideas about it?
    Thanks for your time

    Best regards,
    hb

  2. #2
    Join Date
    Jun 2009
    Posts
    74
    Thanks
    23
    Thanked 2 Times in 2 Posts

    Default Re: Got "the inferior stopped ..." when debug

    btw :
    I do set build configuration to debug mode (windows platform)
    Last edited by hashb; 19th December 2009 at 10:18.

  3. #3
    Join Date
    Jun 2009
    Posts
    74
    Thanks
    23
    Thanked 2 Times in 2 Posts

    Default Re: Got "the inferior stopped ..." when debug

    anyone knows about it?
    I encounter the problem after install qt-sdk-win-opensource-2009.05.exe

    Thanks.
    hb

  4. #4
    Join Date
    Jun 2009
    Posts
    74
    Thanks
    23
    Thanked 2 Times in 2 Posts

    Default Re: Got "the inferior stopped ..." when debug

    Hi All,

    The reason has been found out, it was caused by comodo fire wall,
    it will block the debug feature, I have tried nearly all version of QT4.6 
    to find out the reason.

    Marry X'mas

    Thanks,
    hb

Similar Threads

  1. Qt + Linux + Eclipse - debug using debug build?
    By will49 in forum Qt Programming
    Replies: 6
    Last Post: 13th April 2012, 07:27
  2. Replies: 1
    Last Post: 18th November 2009, 22:51
  3. Debug issues
    By lyucs in forum Qt Tools
    Replies: 4
    Last Post: 13th November 2009, 23:59
  4. Some very weird compilation warnings
    By MarkoSan in forum Qt Programming
    Replies: 21
    Last Post: 23rd January 2008, 17:48
  5. Adding custom defines when on debug build
    By chus in forum Qt Programming
    Replies: 2
    Last Post: 2nd March 2007, 12:38

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.