Results 1 to 2 of 2

Thread: Eclipse woes

  1. #1
    Join Date
    Jan 2010
    Qt products

    Default Eclipse woes

    I tried to compile a test app on Eclipse and got this
    Cannot run program "make": Launching failed

    I set up the directories where all the tools are located and Eclipse is acticing as if they don't exist..arrg
    Last edited by Petr_Kropotkin; 26th January 2010 at 16:02.

  2. #2
    Join Date
    Feb 2010
    Washington, DC
    Qt products
    Qt4 Qt Jambi
    Unix/X11 Windows

    Default Re: Eclipse woes

    I ran into the same problem on Windows. The fix seems a bit unnatural (at least not intuitive), and I hope to see a better solution in the future.

    In the Start Menu, the Qt plug-in should be installed under an entry such as "Qt Eclipse Integration vX.X.X".
    Within that menu folder should be found a launcher for "Start Eclipse with MinGW".

    Apparently, if you want to use the Qt plug-in for Eclipse, you need to start Eclipse using the "Start Eclipse with MinGW" shortcut.

    This solves the error you received for me. It launches a special Command window, not a batch file, which apparently configures and then launches Eclipse. I don't know of any other Eclipse plug-ins with this behavior.

    Unfortunately, even the simple sample AddressBook project with no added code still doesn't build for me, it looks like my first error is
    "tmain_win.cpp:93: undefined reference to `_Unwind_Resume'". I'm working on that, but hopefully you'll have better luck.


Similar Threads

  1. Replies: 7
    Last Post: 22nd December 2010, 08:13
  2. More SQLite Woes and onFocus Woes
    By morraine in forum Newbie
    Replies: 1
    Last Post: 13th August 2008, 13:14
  3. Once more : QAbstractItemModel woes
    By Valheru in forum Qt Programming
    Replies: 10
    Last Post: 15th January 2008, 10:44
  4. OCI w/ VS 2003 woes...
    By croftj in forum Installation and Deployment
    Replies: 5
    Last Post: 7th February 2007, 10:28
  5. QGridLayout woes
    By para in forum Newbie
    Replies: 3
    Last Post: 16th October 2006, 22:41


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.