Results 1 to 2 of 2

Thread: required glibc version?

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Apr 2010
    Posts
    2
    Qt products
    Qt/Embedded
    Platforms
    Unix/X11

    Question required glibc version?

    Hi,

    I looked all over but cannot find the answer to this question.

    When I cross compile applications for the embedded build of Qt-4.6.2 and try to run it, it says
    glibc-2.10.1 cannot be found and that it is required by libQtNetwork.so.

    My embedded platform is Angstrom and libc version is 2.9.
    Are there ways to make it work on libc-2.9 ?

    Regards,
    otsuki

  2. #2
    Join Date
    Apr 2010
    Location
    Belgium
    Posts
    2
    Qt products
    Qt4 Qt/Embedded
    Platforms
    Unix/X11

    Default

    Why is your cross compilation toolchain using a different glibc version than your embedded platform? :-s

    You could try to create a symlink pointing glibc-2.10.1 to glibc-2.9, I guess, but I don't know if that 's a good idea, really...
    Last edited by wysota; 4th May 2010 at 21:35.

Similar Threads

  1. qt-4.5.0 requires glibc>=2.3.2?
    By mailtome in forum Installation and Deployment
    Replies: 1
    Last Post: 9th April 2009, 05:33
  2. Replies: 5
    Last Post: 5th October 2008, 06:12
  3. glibc detected
    By raghvendramisra in forum Qt Programming
    Replies: 5
    Last Post: 28th May 2008, 04:29
  4. Error: **** glibc detected ****
    By Manohar in forum Qt Programming
    Replies: 2
    Last Post: 9th May 2008, 06:32
  5. itemChange() glibc invalid pointer
    By dreamer in forum Qt Programming
    Replies: 2
    Last Post: 3rd May 2008, 10:04

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.