Results 1 to 13 of 13

Thread: need help building code to incorporate mysql plugin

  1. #1
    Join Date
    Sep 2010
    Posts
    6
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default need help building code to incorporate mysql plugin

    Hi,

    I did a cursory search for my situation, and I did not find anything helpful. I downloaded Qt SDK 4.7: Complete Development Environment for my fedora 11. I was playing with the demo/sqlbrowser, and I was hoping to connect to my mysql database. I read I had to 'configure -v -qt-sql-mysql' and compile the source. After I did my configure, I did a gmake, but I ran into errors:

    Qt Code:
    1. f.o painting/qpdf.cpp
    2. In file included from ../../include/QtGui/private/qcups_p.h:1,
    3. from painting/qpdf.cpp:47:
    4. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:61:23: error: cups/cups.h: No such file or directory
    5. In file included from ../../include/QtGui/private/qcups_p.h:1,
    6. from painting/qpdf.cpp:47:
    7. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:65: error: ‘cups_option_t’ was not declared in this scope
    8. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:65: error: template argument 1 is invalid
    9. In file included from ../../include/QtGui/private/qcups_p.h:1,
    10. from painting/qpdf.cpp:47:
    11. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:76: error: ISO C++ forbids declaration of ‘cups_dest_t’ with no type
    12. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:76: error: expected ‘;’ before ‘*’ token
    13. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:78: error: ISO C++ forbids declaration of ‘ppd_file_t’ with no type
    14. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:78: error: expected ‘;’ before ‘*’ token
    15. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:80: error: ISO C++ forbids declaration of ‘ppd_file_t’ with no type
    16. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:80: error: expected ‘;’ before ‘*’ token
    17. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:81: error: ISO C++ forbids declaration of ‘ppd_option_t’ with no type
    18. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:81: error: expected ‘;’ before ‘*’ token
    19. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:83: error: ISO C++ forbids declaration of ‘cups_option_t’ with no type
    20. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:83: error: expected ‘;’ before ‘*’ token
    21. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:84: error: ISO C++ forbids declaration of ‘ppd_option_t’ with no type
    22. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:84: error: expected ‘;’ before ‘*’ token
    23. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:87: error: ISO C++ forbids declaration of ‘type name’ with no type
    24. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:87: error: template argument 1 is invalid
    25. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:100: error: ‘cups_option_t’ has not been declared
    26. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:103: error: ISO C++ forbids declaration of ‘ppd_group_t’ with no type
    27. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:103: error: expected ‘,’ or ‘...’ before ‘*’ token
    28. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:104: error: ISO C++ forbids declaration of ‘ppd_group_t’ with no type
    29. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:104: error: expected ‘,’ or ‘...’ before ‘*’ token
    30. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:107: error: ISO C++ forbids declaration of ‘cups_dest_t’ with no type
    31. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:107: error: expected ‘;’ before ‘*’ token
    32. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:108: error: ISO C++ forbids declaration of ‘ppd_option_t’ with no type
    33. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:108: error: expected ‘;’ before ‘*’ token
    34. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:110: error: ISO C++ forbids declaration of ‘ppd_file_t’ with no type
    35. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:110: error: expected ‘;’ before ‘*’ token
    36. In file included from ../../include/QtGui/private/qcups_p.h:1,
    37. from painting/qpdf.cpp:47:
    38. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h: In static member function ‘static int QCUPSSupport::cupsVersion()’:
    39. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:74: error: ‘CUPS_VERSION_MAJOR’ was not declared in this scope
    40. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:74: error: ‘CUPS_VERSION_MINOR’ was not declared in this scope
    41. ../../include/QtGui/private/../../../src/gui/painting/qcups_p.h:74: error: ‘CUPS_VERSION_PATCH’ was not declared in this scope
    42. painting/qpdf.cpp: In constructor ‘QPdfBaseEngine::QPdfBaseEngine(QPdfBaseEnginePrivate&, QFlags<QPaintEngine::PaintEngineFeature>)’:
    43. painting/qpdf.cpp:946: error: expected initializer before ‘*’ token
    44. painting/qpdf.cpp:950: error: ‘printers’ was not declared in this scope
    45. painting/qpdf.cpp: In member function ‘void QPdfBaseEnginePrivate::closePrintDevice()’:
    46. painting/qpdf.cpp:1849: error: ‘cups_option_t’ was not declared in this scope
    47. painting/qpdf.cpp:1849: error: template argument 1 is invalid
    48. painting/qpdf.cpp:1849: error: invalid type in declaration before ‘;’ token
    49. painting/qpdf.cpp:1904: error: expected ‘;’ before ‘opt’
    50. painting/qpdf.cpp:1905: error: ‘opt’ was not declared in this scope
    51. painting/qpdf.cpp:1907: error: request for member ‘append’ in ‘cupsOptStruct’, which is of non-class type ‘int’
    52. painting/qpdf.cpp:1911: error: ‘optPtr’ was not declared in this scope
    53. painting/qpdf.cpp:1911: error: request for member ‘size’ in ‘cupsOptStruct’, which is of non-class type ‘int’
    54. painting/qpdf.cpp:1911: error: request for member ‘first’ in ‘cupsOptStruct’, which is of non-class type ‘int’
    55. painting/qpdf.cpp:1913: error: request for member ‘size’ in ‘cupsOptStruct’, which is of non-class type ‘int’
    56. gmake[1]: *** [.obj/release-shared/qpdf.o] Error 1
    57. gmake[1]: Leaving directory `/home/bchin/qtsdk-2010.05/qt/src/gui'
    58. gmake: *** [sub-gui-make_default-ordered] Error 2
    To copy to clipboard, switch view to plain text mode 

    I would greatly appreciated if I could get any help compiling the Qt source. Or is my entire approach incorrect?

    Thanks,

    Brad

  2. #2
    Join Date
    Jan 2006
    Location
    Belgium
    Posts
    1,938
    Thanked 268 Times in 268 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows
    Wiki edits
    20

    Default Re: need help building code to incorporate mysql plugin

    Did you follow this guide?
    http://doc.qt.nokia.com/4.7/sql-driver.html

    Quote Originally Posted by b_chin View Post
    Qt Code:
    1. error: cups/cups.h: No such file or directory
    To copy to clipboard, switch view to plain text mode 
    Riddle me this, riddle me that... what is missing?
    I guess you use a linux distro which handles their users as babies. Try installing the cups "dev" package.

  3. #3
    Join Date
    Sep 2010
    Posts
    6
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: need help building code to incorporate mysql plugin

    thank you, I should learn to read the error messages more carefully

  4. #4
    Join Date
    Sep 2010
    Posts
    6
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: need help building code to incorporate mysql plugin

    so i installed the cups "dev" package and GStreamer to get the missing gst.h file. Now I'm running into the following error:

    Qt Code:
    1. .obj/release-shared/mainwindow.o: In function `MainWindow':
    2. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:396: undefined reference to `gst_init_check'
    3. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:397: undefined reference to `gst_version_string'
    4. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_element_factory_get_type'
    5. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_default'
    6. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_feature_list'
    7. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:403: undefined reference to `gst_plugin_feature_get_type'
    8. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_type'
    9. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_klass'
    10. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:406: undefined reference to `gst_plugin_feature_get_type'
    11. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:411: undefined reference to `gst_element_factory_make'
    12. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_type'
    13. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_description'
    14. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:416: undefined reference to `gst_object_unref'
    15. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:396: undefined reference to `gst_init_check'
    16. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:397: undefined reference to `gst_version_string'
    17. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_element_factory_get_type'
    18. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_default'
    19. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_feature_list'
    20. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:403: undefined reference to `gst_plugin_feature_get_type'
    21. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_type'
    22. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_klass'
    23. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:406: undefined reference to `gst_plugin_feature_get_type'
    24. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:411: undefined reference to `gst_element_factory_make'
    25. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_type'
    26. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_description'
    27. /home/bchin/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:416: undefined reference to `gst_object_unref'
    28. collect2: ld returned 1 exit status
    29. gmake[2]: *** [../../bin/qtconfig] Error 1
    30. gmake[2]: Leaving directory `/home/bchin/qtsdk-2010.05/qt/tools/qtconfig'
    31. gmake[1]: *** [sub-qtconfig-make_default-ordered] Error 2
    32. gmake[1]: Leaving directory `/home/bchin/qtsdk-2010.05/qt/tools'
    33. gmake: *** [sub-tools-make_default-ordered] Error 2
    To copy to clipboard, switch view to plain text mode 

    what can I do about this?

  5. #5

    Default Re: need help building code to incorporate mysql plugin

    Hello,

    I'm getting the same error with undefined reference to `gst_init_check'.

    My ./configure command:

    Qt Code:
    1. ./configure -opensource -I /usr/include/gtk-2.0 -I /usr/include/gstreamer-0.10 -I /usr/include/glib-2.0 -I /usr/include/libxml2 -L /usr/lib/gstreamer-0.10 -fast
    To copy to clipboard, switch view to plain text mode 

    Thanks for any help.

  6. #6
    Join Date
    Jan 2008
    Location
    Davao City, Philippines
    Posts
    77
    Thanks
    16
    Thanked 4 Times in 4 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: need help building code to incorporate mysql plugin

    ' undefined reference to' means normally, there is a library missing, one of gstreamers plugins may be.


    Added after 4 minutes:


    Quote Originally Posted by ludek.vodicka View Post
    Qt Code:
    1. ./configure -opensource -I /usr/include/gtk-2.0 -I /usr/include/gstreamer-0.10 -I /usr/include/glib-2.0 -I /usr/include/libxml2 -L /usr/lib/gstreamer-0.10 -fast
    To copy to clipboard, switch view to plain text mode 
    There is normally no need to add all the lib's and includes manually bc Qt will find it without doing that. If not, then there is something wrong with your Linux configuration itself. Have you checked your PATH variable for example?
    Last edited by gboelter; 29th October 2010 at 18:40.
    DavaoSOFT, the home of ERPel
    ERPel, das deutsche Warenwirtschaftssystem fuer LINUX
    http://www.davaosoft.com

  7. #7

    Default Re: need help building code to incorporate mysql plugin

    Thank you for reply. My path:

    Qt Code:
    1. echo $PATH;
    2. /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
    To copy to clipboard, switch view to plain text mode 

    Without -I params I have lot of missing header files. OS is Ubuntu 10.10 clean installation. Maybe I miss something, because I'm linux newbie ;-)

  8. #8
    Join Date
    Jan 2008
    Location
    Davao City, Philippines
    Posts
    77
    Thanks
    16
    Thanked 4 Times in 4 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: need help building code to incorporate mysql plugin

    What about this: Try to install Qt via apt-get bc this normally will already fix all the dependency problems. That's not a big step and after that try to compile it again form the source.
    DavaoSOFT, the home of ERPel
    ERPel, das deutsche Warenwirtschaftssystem fuer LINUX
    http://www.davaosoft.com

  9. #9

    Default Re: need help building code to incorporate mysql plugin

    I tried to install libqt4-dev, libqt4-dbg, libqtcore4, libqtqui4 but none of this helps. All of this packages was alerady installet and compilation still returns following errors:

    Qt Code:
    1. /release-shared/mainwindow.o: In function `MainWindow':
    2. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:396: undefined reference to `gst_init_check'
    3. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:397: undefined reference to `gst_version_string'
    4. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_element_factory_get_type'
    5. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_default'
    6. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_feature_list'
    7. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:403: undefined reference to `gst_plugin_feature_get_type'
    8. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_type'
    9. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_klass'
    10. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:406: undefined reference to `gst_plugin_feature_get_type'
    11. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:411: undefined reference to `gst_element_factory_make'
    12. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_type'
    13. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_description'
    14. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:416: undefined reference to `gst_object_unref'
    15. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:396: undefined reference to `gst_init_check'
    16. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:397: undefined reference to `gst_version_string'
    17. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_element_factory_get_type'
    18. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_default'
    19. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:400: undefined reference to `gst_registry_get_feature_list'
    20. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:403: undefined reference to `gst_plugin_feature_get_type'
    21. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_type'
    22. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:404: undefined reference to `gst_element_factory_get_klass'
    23. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:406: undefined reference to `gst_plugin_feature_get_type'
    24. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:411: undefined reference to `gst_element_factory_make'
    25. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_type'
    26. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:413: undefined reference to `gst_element_factory_get_description'
    27. /home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig/mainwindow.cpp:416: undefined reference to `gst_object_unref'
    28. collect2: ld returned 1 exit status
    29. make[2]: *** [../../bin/qtconfig] Error 1
    30. make[2]: Leaving directory `/home/ludekvodicka/qtsdk-2010.05-x64/qt/tools/qtconfig'
    31. make[1]: *** [sub-qtconfig-make_default-ordered] Error 2
    32. make[1]: Leaving directory `/home/ludekvodicka/qtsdk-2010.05-x64/qt/tools'
    33. make: *** [sub-tools-make_default-ordered] Error 2
    To copy to clipboard, switch view to plain text mode 

    Thanks for help

  10. #10
    Join Date
    Jan 2008
    Location
    Davao City, Philippines
    Posts
    77
    Thanks
    16
    Thanked 4 Times in 4 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: need help building code to incorporate mysql plugin

    Try 'apt-get install gstreamer*' and look, what apt is offering you to install.
    DavaoSOFT, the home of ERPel
    ERPel, das deutsche Warenwirtschaftssystem fuer LINUX
    http://www.davaosoft.com

  11. #11

    Default Re: need help building code to incorporate mysql plugin

    I tried to install all packages with gstreamer* name, but it doesn't help ;(. The error message from make is still the same.

    Here is apt-get output:

    Qt Code:
    1. sudo apt-get install gstreamer*
    2. Reading package listsDone
    3. Building dependency tree
    4. Reading state informationDone
    5. Note, selecting 'bluez-gstreamer' for regex 'gstreamer*'
    6. 'libgstreamer-plugins-base0.10-0' for regex 'gstreamer*'
    7. 'libgstreamer0.10-0' for regex 'gstreamer*'
    8. 'gstreamer0.10-plugins-base' for regex 'gstreamer*'
    9. 'gstreamer0.10-plugins-good' for regex 'gstreamer*'
    10. 'gstreamer0.10-x' for regex 'gstreamer*'
    11. 'gir1.0-gstreamer-0.10' for regex 'gstreamer*'
    12. 'gstreamer0.10-alsa' for regex 'gstreamer*'
    13. 'gstreamer0.10-audiosink' for regex 'gstreamer*'
    14. 'gstreamer-tools' for regex 'gstreamer*'
    15. 'gstreamer0.10-tools' for regex 'gstreamer*'
    16. 'gstreamer0.8-tools' for regex 'gstreamer*'
    17. 'gstreamer0.10-audiosource' for regex 'gstreamer*'
    18. 'gstreamer0.10-doc' for regex 'gstreamer*'
    19. 'libgstreamer0.10-dev' for regex 'gstreamer*'
    20. 'gstreamer0.10-esd' for regex 'gstreamer*'
    21. 'gstreamer0.10-gnonlin' for regex 'gstreamer*'
    22. 'gstreamer0.10-gnonlin-dbg' for regex 'gstreamer*'
    23. 'gstreamer0.10-nice' for regex 'gstreamer*'
    24. 'gstreamer0.10-plugins-bad' for regex 'gstreamer*'
    25. 'gstreamer0.10-videosource' for regex 'gstreamer*'
    26. 'gstreamer0.10-plugins-base-apps' for regex 'gstreamer*'
    27. 'gstreamer0.10-plugins-base-dbg' for regex 'gstreamer*'
    28. 'gstreamer0.10-gnomevfs' for regex 'gstreamer*'
    29. 'gstreamer0.10-plugins-bad-dbg' for regex 'gstreamer*'
    30. 'gstreamer0.10-plugins-really-bad' for regex 'gstreamer*'
    31. 'gstreamer0.10-videosink' for regex 'gstreamer*'
    32. 'gstreamer0.10-visualization' for regex 'gstreamer*'
    33. 'gstreamer0.10-plugins-good-dbg' for regex 'gstreamer*'
    34. 'gstreamer0.10-pulseaudio' for regex 'gstreamer*'
    35. 'gstreamer0.10-fluendo-mp3' for regex 'gstreamer*'
    36. 'gstreamer0.10-plugins-ugly' for regex 'gstreamer*'
    37. 'libcanberra-gstreamer' for regex 'gstreamer*'
    38. 'libcanberra-gstreamer-dbg' for regex 'gstreamer*'
    39. 'gstreamer-codec-install' for regex 'gstreamer*'
    40. 'totem-gstreamer' for regex 'gstreamer*'
    41. 'libgstreamer-plugins-base0.10-dev' for regex 'gstreamer*'
    42. 'gstreamer0.10-plugins' for regex 'gstreamer*'
    43. 'libgstreamer0.10-0-dbg' for regex 'gstreamer*'
    44. 'phonon-backend-gstreamer' for regex 'gstreamer*'
    45. 'gstreamer0.10-ffmpeg' for regex 'gstreamer*'
    46. 'gstreamer0.10-plugins-ugly-dbg' for regex 'gstreamer*'
    47. 'gstreamer0.10-plugins-bad-multiverse' for regex 'gstreamer*'
    48. 'gstreamer0.10-plugins-ugly-multiverse' for regex 'gstreamer*'
    49. 'gstreamer0.10-buzztard' for regex 'gstreamer*'
    50. 'gstreamer0.10-plugins-cutter' for regex 'gstreamer*'
    51. 'deejayd-gstreamer' for regex 'gstreamer*'
    52. 'libgstreamer-perl' for regex 'gstreamer*'
    53. 'gstreamer0.10-plugins-ugly-doc' for regex 'gstreamer*'
    54. 'gstreamer-dbus-media-service' for regex 'gstreamer*'
    55. 'gstreamer0.10-buzztard-doc' for regex 'gstreamer*'
    56. 'gstreamer0.10-ffmpeg-dbg' for regex 'gstreamer*'
    57. 'gstreamer0.10-packagekit' for regex 'gstreamer*'
    58. 'gstreamer0.10-fluendo-mpegdemux' for regex 'gstreamer*'
    59. 'gstreamer0.10-fluendo-mpegmux' for regex 'gstreamer*'
    60. 'gstreamer0.10-plugins-farsight' for regex 'gstreamer*'
    61. 'gstreamer0.10-schroedinger' for regex 'gstreamer*'
    62. 'gstreamer0.10-sdl' for regex 'gstreamer*'
    63. 'gstreamer0.10-plugins-bad-doc' for regex 'gstreamer*'
    64. 'gstreamer0.10-pocketsphinx' for regex 'gstreamer*'
    65. 'libghc6-gstreamer-dev' for regex 'gstreamer*'
    66. 'libghc6-gstreamer-doc' for regex 'gstreamer*'
    67. 'libghc6-gstreamer-prof' for regex 'gstreamer*'
    68. 'libghc6-gstreamer-dev-0.11.0-785d1' for regex 'gstreamer*'
    69. 'libghc6-gstreamer-prof-0.11.0-785d1' for regex 'gstreamer*'
    70. 'libgstreamer-interfaces-perl' for regex 'gstreamer*'
    71. 'libgstreamermm-0.10-2' for regex 'gstreamer*'
    72. 'libgstreamermm-0.10-dbg' for regex 'gstreamer*'
    73. 'libgstreamermm-0.10-dev' for regex 'gstreamer*'
    74. 'libgstreamermm-0.10-doc' for regex 'gstreamer*'
    75. 'gstreamer0.10-lame' for regex 'gstreamer*'
    76. 'gstreamer0.10-ffmpeg-full' for regex 'gstreamer*'
    77. 'gstreamer0.10-plugins-bad-multiverse-dbg' for regex 'gstreamer*'
    78. 'gstreamer0.10-plugins-ugly-multiverse-dbg' for regex 'gstreamer*'
    79. 'gstreamer0.10-plugins-good' instead of 'gstreamer0.10-visualization'
    80. 'libghc6-gstreamer-dev' instead of 'libghc6-gstreamer-dev-0.11.0-785d1'
    81. 'libghc6-gstreamer-prof' instead of 'libghc6-gstreamer-prof-0.11.0-785d1'
    82. 'gstreamer0.10-plugins-ugly-multiverse' instead of 'gstreamer0.10-lame'
    83. bluez-gstreamer is already the newest version.
    84. gir1.0-gstreamer-0.10 is already the newest version.
    85. gstreamer0.10-alsa is already the newest version.
    86. gstreamer0.10-gnonlin is already the newest version.
    87. gstreamer0.10-nice is already the newest version.
    88. gstreamer0.10-plugins-base is already the newest version.
    89. gstreamer0.10-plugins-base-apps is already the newest version.
    90. gstreamer0.10-plugins-good is already the newest version.
    91. gstreamer0.10-pulseaudio is already the newest version.
    92. gstreamer0.10-tools is already the newest version.
    93. gstreamer0.10-x is already the newest version.
    94. libgstreamer-plugins-base0.10-0 is already the newest version.
    95. libgstreamer0.10-0 is already the newest version.
    96. libgstreamer0.10-dev is already the newest version.
    97. gstreamer0.10-ffmpeg is already the newest version.
    98. gstreamer0.10-fluendo-mp3 is already the newest version.
    99. gstreamer0.10-plugins-bad is already the newest version.
    100. gstreamer0.10-plugins-ugly is already the newest version.
    101. The following extra packages will be installed:
    102. buzztard buzztard-data cutter-testing-framework-bin deejayd-gstreamer
    103. esound-clients esound-common ghc6 ghc6-doc ghc6-prof
    104. gstreamer-dbus-media-service gstreamer-tools gstreamer0.10-buzztard
    105. gstreamer0.10-buzztard-doc gstreamer0.10-doc gstreamer0.10-esd
    106. gstreamer0.10-ffmpeg-dbg gstreamer0.10-gnomevfs gstreamer0.10-gnonlin-dbg
    107. gstreamer0.10-gnonlin-doc gstreamer0.10-packagekit
    108. gstreamer0.10-plugins-bad-dbg gstreamer0.10-plugins-bad-doc
    109. gstreamer0.10-plugins-bad-multiverse
    110. gstreamer0.10-plugins-bad-multiverse-dbg gstreamer0.10-plugins-base-dbg
    111. gstreamer0.10-plugins-base-doc gstreamer0.10-plugins-cutter
    112. gstreamer0.10-plugins-good-dbg gstreamer0.10-plugins-good-doc
    113. gstreamer0.10-plugins-ugly-dbg gstreamer0.10-plugins-ugly-doc
    114. gstreamer0.10-plugins-ugly-multiverse
    115. gstreamer0.10-plugins-ugly-multiverse-dbg gstreamer0.10-pocketsphinx
    116. gstreamer0.10-sdl libaudiofile0 libbml0 libbsd-dev libbuzztard0
    117. libcanberra-gstreamer libcanberra-gstreamer-dbg libcutter-dev libcutter0
    118. libesd0 libextutils-depends-perl libextutils-pkgconfig-perl libfaac0
    119. libffi-dev libfluidsynth1 libghc6-glib-dev libghc6-glib-doc
    120. libghc6-glib-prof libghc6-gstreamer-dev libghc6-gstreamer-doc
    121. libghc6-gstreamer-prof libghc6-mtl-dev libghc6-mtl-doc libghc6-mtl-prof
    122. libglib2.0-doc libglibmm-2.4-dev libgmp3-dev libgmpxx4ldbl libgsf-1-114
    123. libgsf-1-common libgstbuzztard0 libgstreamer-interfaces-perl
    124. libgstreamer-perl libgstreamer-plugins-base0.10-dev libgstreamer0.10-0-dbg
    125. libgstreamermm-0.10-2 libgstreamermm-0.10-dbg libgstreamermm-0.10-dev
    126. libgstreamermm-0.10-doc liblash3 libmjpegtools-1.9 libmp3lame0
    127. libpackagekit-glib2-14 libpocketsphinx1 libquicktime1 libsigc++-2.0-dev
    128. libsphinxbase1 libx264-98 libxml++2.6-2 libxml++2.6-dev libxml2-doc
    129. libxvidcore4 lsdvd packagekit packagekit-backend-aptcc
    130. phonon-backend-gstreamer pocketsphinx-hmm-wsj1 pocketsphinx-lm-wsj
    131. pocketsphinx-utils python-packagekit totem-gstreamer
    132. Suggested packages:
    133. buzztard-bsl lcov haskell-doc libgtk2.0-doc libglibmm-2.4-doc
    134. libgtkmm-2.4-dev libgmp3-doc libmpfr-dev libsigc++-2.0-doc libxml++2.6-doc
    135. devhelp packagekit-backend-apt packagekit-backend-smart
    136. The following NEW packages will be installed:
    137. buzztard buzztard-data cutter-testing-framework-bin deejayd-gstreamer
    138. esound-clients esound-common ghc6 ghc6-doc ghc6-prof
    139. gstreamer-dbus-media-service gstreamer-tools gstreamer0.10-buzztard
    140. gstreamer0.10-buzztard-doc gstreamer0.10-doc gstreamer0.10-esd
    141. gstreamer0.10-ffmpeg-dbg gstreamer0.10-gnomevfs gstreamer0.10-gnonlin-dbg
    142. gstreamer0.10-gnonlin-doc gstreamer0.10-packagekit
    143. gstreamer0.10-plugins-bad-dbg gstreamer0.10-plugins-bad-doc
    144. gstreamer0.10-plugins-bad-multiverse
    145. gstreamer0.10-plugins-bad-multiverse-dbg gstreamer0.10-plugins-base-dbg
    146. gstreamer0.10-plugins-base-doc gstreamer0.10-plugins-cutter
    147. gstreamer0.10-plugins-good-dbg gstreamer0.10-plugins-good-doc
    148. gstreamer0.10-plugins-ugly-dbg gstreamer0.10-plugins-ugly-doc
    149. gstreamer0.10-plugins-ugly-multiverse
    150. gstreamer0.10-plugins-ugly-multiverse-dbg gstreamer0.10-pocketsphinx
    151. gstreamer0.10-sdl libaudiofile0 libbml0 libbsd-dev libbuzztard0
    152. libcanberra-gstreamer libcanberra-gstreamer-dbg libcutter-dev libcutter0
    153. libesd0 libextutils-depends-perl libextutils-pkgconfig-perl libfaac0
    154. libffi-dev libfluidsynth1 libghc6-glib-dev libghc6-glib-doc
    155. libghc6-glib-prof libghc6-gstreamer-dev libghc6-gstreamer-doc
    156. libghc6-gstreamer-prof libghc6-mtl-dev libghc6-mtl-doc libghc6-mtl-prof
    157. libglib2.0-doc libglibmm-2.4-dev libgmp3-dev libgmpxx4ldbl libgsf-1-114
    158. libgsf-1-common libgstbuzztard0 libgstreamer-interfaces-perl
    159. libgstreamer-perl libgstreamer-plugins-base0.10-dev libgstreamer0.10-0-dbg
    160. libgstreamermm-0.10-2 libgstreamermm-0.10-dbg libgstreamermm-0.10-dev
    161. libgstreamermm-0.10-doc liblash3 libmjpegtools-1.9 libmp3lame0
    162. libpackagekit-glib2-14 libpocketsphinx1 libquicktime1 libsigc++-2.0-dev
    163. libsphinxbase1 libx264-98 libxml++2.6-2 libxml++2.6-dev libxml2-doc
    164. libxvidcore4 lsdvd packagekit packagekit-backend-aptcc
    165. phonon-backend-gstreamer pocketsphinx-hmm-wsj1 pocketsphinx-lm-wsj
    166. pocketsphinx-utils python-packagekit totem-gstreamer
    167. 0 upgraded, 95 newly installed, 0 to remove and 0 not upgraded.
    168. Need to get 157MB of archives.
    169. After this operation, 871MB of additional disk space will be used.
    To copy to clipboard, switch view to plain text mode 

  12. #12
    Join Date
    Aug 2010
    Posts
    3
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: need help building code to incorporate mysql plugin

    Was this ever solved?

    I am getting the same error on Ubuntu 10.10 x64

    Thanks,

  13. #13
    Join Date
    Mar 2011
    Posts
    1
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: need help building code to incorporate mysql plugin

    I got around the error. The last message, while compiling Qt 4.7.0 on Linux/X11, was:

    Qt Code:
    1. make[2]: Entering directory `/opt/qtsdk-2010.05/qt/tools/qtconfig'
    2. g++ -Wl,-rpath-link,/opt/qtsdk-2010.05/qt/lib -m64 -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.7.0/lib -Wl,-rpath,/usr/local/Trolltech/Qt-4.7.0/lib -o ../../bin/qtconfig .obj/release-shared/colorbutton.o .obj/release-shared/main.o .obj/release-shared/previewframe.o .obj/release-shared/previewwidget.o .obj/release-shared/mainwindow.o .obj/release-shared/paletteeditoradvanced.o .obj/release-shared/mainwindowbase.o .obj/release-shared/paletteeditoradvancedbase.o .obj/release-shared/previewwidgetbase.o .obj/release-shared/moc_colorbutton.o .obj/release-shared/moc_previewframe.o .obj/release-shared/moc_previewwidget.o .obj/release-shared/moc_mainwindow.o .obj/release-shared/moc_paletteeditoradvanced.o .obj/release-shared/moc_mainwindowbase.o .obj/release-shared/moc_paletteeditoradvancedbase.o .obj/release-shared/moc_previewwidgetbase.o .obj/release-shared/qrc_qtconfig.o -L/opt/qtsdk-2010.05/qt/lib -L/usr/X11R6/lib64 -lQt3Support -L/opt/qtsdk-2010.05/qt/lib -lQtSql -lQtXml -L/usr/X11R6/lib64 -lQtNetwork -lQtGui -lQtCore -lpthread -lXrender -lfontconfig -lfreetype -lXext -lX11 -lm
    3. .obj/release-shared/mainwindow.o: In function `MainWindow':
    4. /opt/qtsdk-2010.05/qt/tools/qtconfig/mainwindow.cpp:396: undefined reference to `gst_init_check'
    To copy to clipboard, switch view to plain text mode 

    and so on with the undefined references. I manually went to the dir /opt/qtsdk-2010.05/qt/tools/qtconfig and added "-lgstreamer-0.10" to the long g++ line and "entered it", like so:

    Qt Code:
    1. cd tools/qtconfig
    2. g++ -Wl,-rpath-link,/opt/qtsdk-2010.05/qt/lib -m64 -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.7.0/lib -Wl,-rpath,/usr/local/Trolltech/Qt-4.7.0/lib -o ../../bin/qtconfig .obj/release-shared/colorbutton.o .obj/release-shared/main.o .obj/release-shared/previewframe.o .obj/release-shared/previewwidget.o .obj/release-shared/mainwindow.o .obj/release-shared/paletteeditoradvanced.o .obj/release-shared/mainwindowbase.o .obj/release-shared/paletteeditoradvancedbase.o .obj/release-shared/previewwidgetbase.o .obj/release-shared/moc_colorbutton.o .obj/release-shared/moc_previewframe.o .obj/release-shared/moc_previewwidget.o .obj/release-shared/moc_mainwindow.o .obj/release-shared/moc_paletteeditoradvanced.o .obj/release-shared/moc_mainwindowbase.o .obj/release-shared/moc_paletteeditoradvancedbase.o .obj/release-shared/moc_previewwidgetbase.o .obj/release-shared/qrc_qtconfig.o -L/opt/qtsdk-2010.05/qt/lib -L/usr/X11R6/lib64 -lQt3Support -L/opt/qtsdk-2010.05/qt/lib -lQtSql -lQtXml -L/usr/X11R6/lib64 -lQtNetwork -lQtGui -lQtCore -lpthread -lXrender -lfontconfig -lfreetype -lXext -lX11 -lm -lgstreamer-0.10
    3.  
    4. <no error, got prompt back>
    5.  
    6. cd -
    7.  
    8. /opt/qtsdk-2010.05/qt
    9.  
    10. make
    To copy to clipboard, switch view to plain text mode 

    After this g++ line-by-hand, the make command finished without errors, and the make install went fine too.

    The file libgstreamer-0.10.so (which is used) comes in CentOS from the gstreamer-devel, so you have to install that package. My whole "configure line" was:

    Qt Code:
    1. ./configure -I /usr/include/gtk-2.0 -I /usr/include/gstreamer-0.10 -I /usr/include/glib-2.0 -I /usr/include/libxml2 -I /usr/lib64/glib-2.0/include
    To copy to clipboard, switch view to plain text mode 

    I hope this helps anyone

    By the way, using qt-everywhere-opensource-src-4.7.2 this fix is not necessary anymore. The above fix is for 4.7.0 from qtsdk-2010.05. I have just rebuilt 4.7.2 with only the above configure line, and all went fine.
    Last edited by Gerb; 9th March 2011 at 19:43. Reason: update for 4.7.2

Similar Threads

  1. building a plugin for MySql
    By pcaeiro in forum Installation and Deployment
    Replies: 2
    Last Post: 5th August 2009, 12:07
  2. building plugin for mysql?
    By triperzonak in forum Installation and Deployment
    Replies: 1
    Last Post: 25th June 2008, 09:57
  3. How To Incorporate Progress Bar In Program
    By deekayt in forum Qt Programming
    Replies: 8
    Last Post: 20th December 2006, 15:40
  4. Problems building mysql plugin for Qt 4.1.2 on windows XP
    By Philip_Anselmo in forum Installation and Deployment
    Replies: 3
    Last Post: 17th May 2006, 16:38
  5. Building of MySQL plugin fails
    By janca in forum Installation and Deployment
    Replies: 2
    Last Post: 21st January 2006, 09:23

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.