Results 1 to 4 of 4

Thread: QGLWidget, ATI & NVIDIA

  1. #1
    Join Date
    May 2006
    Location
    Stockholm, Sweden
    Posts
    81
    Thanks
    12
    Thanked 1 Time in 1 Post
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11

    Default QGLWidget, ATI & NVIDIA

    Hi!

    I have a Qt program that uses OpenGL in a QGLWidget. It works fine on my computer, which uses Suse10.1 and ATI Radeon9000 card. When the program is compiled and run on a computer that uses Suse9.1 with a Nvidia Quadro4 card, the OpenGL part dont update properly. It only updates the drawing buffer when the window is minimized and expanded.

    Any tips on where to search?

    pir

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,013 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: QGLWidget, ATI & NVIDIA

    Do other OpenGL applications behave properly? What about Qt OpenGL demos?

  3. #3
    Join Date
    May 2006
    Location
    Stockholm, Sweden
    Posts
    81
    Thanks
    12
    Thanked 1 Time in 1 Post
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11

    Default Re: QGLWidget, ATI & NVIDIA

    Yes, the OpenGL examples that come with the Qt installation works fine.

    The other parts of the program work fine also. That is, the window menus and stuff like that. It is the QGLWidget that freezes. So if I spin the object nothing happens untill I minimize the window and then maximize it. When this is done the widget is able to update the buffer.
    So there seems to be some updating problem.

    Is there any problem with g++3.3 and Qt? I use g++ 4.something and the other computer uses g++3.3.

    I'm completely NULL on where to look.

    pir

  4. #4
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,013 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: QGLWidget, ATI & NVIDIA

    I'd start with debugging the application, for example trying to determine if updateGL() is called when it is needed. Maybe something is "optimising" your applications and causes that incorrect behaviour.

Similar Threads

  1. about QGLWidget and QPainter
    By showhand in forum Qt Programming
    Replies: 5
    Last Post: 12th November 2008, 11:45
  2. QGLWidget with multiple monitors
    By Rayven in forum Qt Programming
    Replies: 3
    Last Post: 4th August 2006, 11:28
  3. QGLWidget renderText()
    By ToddAtWSU in forum Qt Programming
    Replies: 8
    Last Post: 21st July 2006, 14:20
  4. QGLWidget renderText
    By Rayven in forum Qt Programming
    Replies: 2
    Last Post: 14th July 2006, 22:02
  5. QGLWidget updateGL()
    By Lele in forum Qt Programming
    Replies: 7
    Last Post: 30th May 2006, 16:08

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.