Results 1 to 4 of 4

Thread: Build static QT + static SSL problem.

  1. #1
    Join Date
    Feb 2011
    Posts
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Question Build static QT + static SSL problem.

    Hello.
    I'm trying to built static Qt with static SSL. I need exactly static.
    This topic Compiling static for Windows with OpenSSL don't help me.

    My platform: Windows XP sp2, QT 4.4.3, MSVS 2003
    What have i done:

    1. SSL sources from OpenSSL (openssl-1.0.0c) i build staticly.
    Qt Code:
    1. > perl Configure VC-WIN32 no-asm --prefix=c:\mydir\ssl
    2. > ms\do_ms
    3. > nmake -f ms\nt.mak
    4. > nmake -f ms\nt.mak install
    To copy to clipboard, switch view to plain text mode 

    After that i have ssl libs "libeay32.lib" and "ssleay32.lib" in my c:\mydir\ssl\lib. Everything is ok.

    2. Rebuild my QT.
    Qt Code:
    1. > configure -static -platform win32-msvc2003 -openssl-linked -I "c:\mydir\ssl\include" -L "c:\mydir\ssl\lib"
    2. > nmake
    To copy to clipboard, switch view to plain text mode 

    So, nmake print me this:

    Qt Code:
    1. c:\mydir\qt-4.4.3\src\network\ssl\qsslsocket_openssl_symbols_p.h(264) : error C2065: 'STACK' : undeclared identifier
    2. c:\mydir\qt-4.4.3\src\network\ssl\qsslsocket_openssl_symbols_p.h(264) : error C2065: 'a' : undeclared identifier
    3. c:\mydir\qt-4.4.3\src\network\ssl\qsslsocket_openssl_symbols_p.h(264) : error C2182: 'q_sk_free' : illegal use of type 'void'
    4. c:\mydir\qt-4.4.3\src\network\ssl\qsslsocket_openssl_symbols_p.h(264) : fatal error C1903: unable to recover from previous error(s); stopping com
    5. pilation
    6. ...
    7. NMAKE : fatal error U1077: 'cl' : return code '0x2'
    8. Stop.
    9. NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio .NET 2003\VC7\BIN\nmake.exe"' : return code '0x2'
    10. Stop.
    11. NMAKE : fatal error U1077: 'cd' : return code '0x2'
    12. Stop.
    To copy to clipboard, switch view to plain text mode 

    It seems like nmake cannot find ssl sources... But i'm sure this sources is in c:\mydir\ssl\include.

    I have no idea, what i'm doing wrong.
    Can anybody help me about this? Thanks.

  2. #2
    Join Date
    Oct 2006
    Location
    New Delhi, India
    Posts
    2,467
    Thanks
    8
    Thanked 333 Times in 317 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Build static QT + static SSL problem.

    Before starting step 2, Copy OpenSsl(staticly built) directories(include, bin and lib) to Qt include include/bin/lib folders.
    I usually follow the above step while building Qt myself.

  3. #3
    Join Date
    Feb 2011
    Posts
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Build static QT + static SSL problem.

    I tried, It doesnt help...(

    But i find an interesting thing. nmake print:
    Qt Code:
    1. c:\mydir\qt-4.4.3\src\network\ssl\qsslsocket_openssl_symbols_p.h(264) : error C2065: 'STACK' : undeclared identifier
    To copy to clipboard, switch view to plain text mode 
    .
    STACK - is type that was in old versions OpenSSL. I used openssl-1.0.0c and there is _STACK type instead STACK!!!
    Ok, then i took openssl-0.9.8p version. Tried to build again. Files compiled ok, but linker print an error. problem with libeay32.lib...

    well, i'll try to rebuilt all...
    Last edited by makzimi; 7th February 2011 at 14:24.

  4. #4
    Join Date
    Jan 2012
    Posts
    6
    Thanks
    3
    Qt products
    Qt4
    Platforms
    Windows

    Default Re: Build static QT + static SSL problem.

    I have the same problem ... how did you solve it?

Similar Threads

  1. Yet another problem with qt static build on windows
    By Green in forum Qt Programming
    Replies: 1
    Last Post: 4th July 2010, 18:26
  2. Problem Configure openssl static build
    By moh.gup@gmail.com in forum Installation and Deployment
    Replies: 0
    Last Post: 16th March 2010, 17:28
  3. Replies: 1
    Last Post: 13th January 2010, 23:35
  4. Moving from QT 4.5 shared build to QT 4.5.2 static build
    By extrakun in forum Qt Programming
    Replies: 0
    Last Post: 26th October 2009, 09:49
  5. problem after Qt 4.2.2 static build
    By npc in forum Newbie
    Replies: 2
    Last Post: 23rd February 2007, 12:28

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.