Results 1 to 4 of 4

Thread: GLIBCXX error on RHEL5 while installing Qt 4.7.1

  1. #1
    Join Date
    Aug 2010
    Posts
    36
    Thanks
    4
    Qt products
    Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default GLIBCXX error on RHEL5 while installing Qt 4.7.1

    Hi,

    Qt Creator 4.7.1 is not installing on a native RHEL 5 OS. The installer is looking for GLIBCXX_4.3.9 and RHEL 5 only has version GLIBCXX_4.3.8.

    Has anyone ever faced this kind of issue???
    If yes, could you please recommend a solution or workaround for this.

    Regards,
    Raj

  2. #2
    Join Date
    Jan 2006
    Location
    Munich, Germany
    Posts
    4,716
    Thanks
    21
    Thanked 418 Times in 411 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: GLIBCXX error on RHEL5 while installing Qt 4.7.1

    install GLIBCXX_4.3.9.
    ==========================signature=============== ==================
    S.O.L.I.D principles (use them!):
    https://en.wikipedia.org/wiki/SOLID_...iented_design)

    Do you write clean code? - if you are TDD'ing then maybe, if not, your not writing clean code.

  3. #3
    Join Date
    Aug 2010
    Posts
    36
    Thanks
    4
    Qt products
    Qt4 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: GLIBCXX error on RHEL5 while installing Qt 4.7.1

    Well, I can do that ... but our systems team is not recommending that.
    So I just want to know that, Is it a known issue ... Can Qt 4.7.1 be installed on RHEL5 ?? ... because we will have to keep our users informed on that.

    Other work around that I have is to compile Qt 4.7.1 from source code and use it with Qt creator from 4.6.3. This is what I have on couple of my RHEL5 machines.

  4. #4
    Join Date
    Jan 2006
    Location
    Munich, Germany
    Posts
    4,716
    Thanks
    21
    Thanked 418 Times in 411 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Default Re: GLIBCXX error on RHEL5 while installing Qt 4.7.1

    Other work around that I have is to compile Qt 4.7.1 from source code and use it with Qt creator from 4.6.3. This is what I have on couple of my RHEL5 machines.
    Sounds reasonable to me.
    ==========================signature=============== ==================
    S.O.L.I.D principles (use them!):
    https://en.wikipedia.org/wiki/SOLID_...iented_design)

    Do you write clean code? - if you are TDD'ing then maybe, if not, your not writing clean code.

Similar Threads

  1. error about installing qwt
    By dycjiaoda in forum Qwt
    Replies: 2
    Last Post: 8th February 2011, 06:42
  2. Error while installing arm-qtopia
    By Yayati.Ekbote in forum Qt for Embedded and Mobile
    Replies: 0
    Last Post: 10th March 2010, 09:57
  3. Error installing qt
    By superteny in forum Installation and Deployment
    Replies: 1
    Last Post: 18th May 2009, 11:07
  4. Depolyment in Linux RHEL5.1 problem
    By c_srikanth1984 in forum Installation and Deployment
    Replies: 1
    Last Post: 11th April 2009, 12:55
  5. Error Installing Qt 4.2.2 opensource on Mac OS X
    By dvmorris in forum Installation and Deployment
    Replies: 3
    Last Post: 7th March 2007, 20:09

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.