Results 1 to 2 of 2

Thread: 'successfully' installed mobile applications do not launch

  1. #1
    Join Date
    Aug 2010
    Thanked 1 Time in 1 Post
    Qt products
    Windows Symbian S60 Maemo/MeeGo

    Default 'successfully' installed mobile applications do not launch

    I recently acquired a Nokia C5-03 and am trying to deploy Qt applications to a mobile device for the first time. I'm using Qt SDK 1.1.2 since Qt SDK 1.1.4 does not have the shortcuts for installing Qt components to a Symbian 1 device. I installed Qt, Qt Webkit, Qt Mobility, and other components to my phone using the shortcuts. I have installed EnergyProfiler and EnvSelector from Nokia and both are running properly. I am trying to deploy the simplest application possible from Qt Creator to the phone just to test the process. I used Qt Designer to create an app with just one push button. Of course it runs in the simulator. For deployment, I made one change to the .pro file as indicated in the documentation topic 'Creating Self-signed Smart Installer Packages', i.e I pasted the line 'DEPLOYMENT.installer_header=0xA000D7CE' over the commented-out line in the .pro file. In some cases I chose the option to create a smart installer package but in others I didn't. In all cases when I copied to .sis to my phone and installed it, the installation completes successfully with the message 'Installation complete' and the app's icon appears in the 'installed apps' menu alongside icons for EnergyProfiler etc. However, unlike for EnergyProfiler etc, 'clicking' on the icon does not launch the app. In cases where I created a Smart Installer package and tried to install it, the installation does not complete successfully. The phone downloads 6.47 MB from the Internet and installation continues but eventually fails with the message 'Installation failed' followed by the message 'to continue installation later click on the Smart Installer icon'. Doing so merely repeats the cycle. Can anyone identify the problem or can anyone tell me the simplest way to deploy the simplest Qt application (self-signed) to my (Nokia C5-03, S60 5th edition) phone?.

  2. #2
    Join Date
    Jun 2010
    Thanked 1 Time in 1 Post
    Qt products

    Default Re: 'successfully' installed mobile applications do not launch

    Hello Rakula,

    I have a similar problem with the SDK 1.1.2. My phone is a Nokia N95 8GB. I have installed serveral times again the SDK without any success.
    My problem is: N95 supports only Qt 4.6.3, but the default SDK installation uses 4.7.3. There is no chance about "maintain" or "update" the SDK about the links contained in the program-group of SDK (windows XP).

    But the strange thing is: Yes, there are a serveral links for installing TRK on S60 5th FPx. I did it and: Sure, it works.
    Missing the 4.6.3 libs inside th SDK directory I re-installed the SDK once again, custom-choose now. i checked the Symbian 4.6.3 modules only.
    Watching to the directory I found serveral .sis files. I tried it to install... and it works. The examples are running greatfully.

    Then I started to develop a simple "hello world" program with QtCreator. But it failed to compile. There are no Qt libs existing! What the f... is that!

    No chance to find out what went wrong. Ok, once again re-installing. Now with both 4.6.3. and 4.7.3. But the installing process stopped at 99% during installing something like called "epoc.exe". What the f... again!

    What's the result of my experience and can help you:
    Maybe you have to make sure the libs of your app uses the same libs installed on your nokia mobile. Your behaviour sounds like the libs onto your mobile are not the same you using during compiling.

    Look at me, installing examples about .sis works (I don't know from where the libs were pulled!), but my own sample not.


Similar Threads

  1. Replies: 0
    Last Post: 12th April 2011, 08:34
  2. QT use cmake dose not work successfully.
    By wter27 in forum Qt Programming
    Replies: 1
    Last Post: 7th February 2011, 10:26
  3. Qt 4.7 and Visual Studio 2010 - cannot launch compiled Qt Applications
    By Schreihals in forum Installation and Deployment
    Replies: 1
    Last Post: 31st January 2011, 12:28
  4. mobile extensions problems in Qt mobile app
    By hasnain in forum Qt for Embedded and Mobile
    Replies: 0
    Last Post: 31st December 2010, 12:29
  5. Replies: 1
    Last Post: 22nd September 2010, 16:39


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.