Results 1 to 6 of 6

Thread: Qt on Ubuntu 10.04 from Ubuntu packages?

  1. #1
    Join Date
    Feb 2009
    Posts
    13
    Thanks
    3
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Qt on Ubuntu 10.04 from Ubuntu packages?

    What is the correct way to install Qt from the Ubuntu package sources on Ubuntu 10.04?

    Somehow I managed to install Qt on my machine from the Ubuntu packages and I could compile some example programs. This was about a week ago. Then, I tried to install qwt, from the package sources as well, but since then Qt has not worked at all.

    I have tried to totally remove Qt from Synaptic and re-install it but all attempts have failed

    sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui

    is my latest attempt.

    What I noticed, is that the non-working installation uses an older version of qmake than the version that compiled the example snippets a week ago. There is some older stuff on the machine that cannot be erased by removing the packages from synaptic??

    If I try to install Qt with the Nokia installer, how can I remove all the files and reset the state of my machine to the original state when I need the space for something else?


    teele

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Qt on Ubuntu 10.04 from Ubuntu packages?

    I don't have any problems with Qt installed using apt from default (k)ubuntu repositories.
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  3. #3
    Join Date
    Feb 2009
    Posts
    13
    Thanks
    3
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: Qt on Ubuntu 10.04 from Ubuntu packages?

    I got qt working when I removed every and each qwt related package from Synaptic. The question changes a bit, then. Could I get qwt from the Ubuntu packages so that I do not confuse the working qt on my machine?

    What would be the command line for getting qwt safely from the packages. My Ubuntu version is 10.04.

    teele

  4. #4
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Qt on Ubuntu 10.04 from Ubuntu packages?

    apt-get install libqwt-dev
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  5. #5
    Join Date
    Feb 2009
    Posts
    13
    Thanks
    3
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: Qt on Ubuntu 10.04 from Ubuntu packages?

    I just tried

    apt-get install libqwt-dev

    but it didn't give a working system. In fact, the entire qt was confused after that.

    Then, I tried removing qwt but, still, the system was not working. After some remove and reinstall cycles of qt with autoremove commands, I finally got my qt back. There is no qwt, which seems to be the problem not only for qwt itself but for the entire qt system on my machine.

    It is interesting that the

    apt-get install libqwt-dev

    command works on your machine but not on mine. I have a standard Ubuntu 10.04 installation with no personal tweaks.

    Could I get an animated sine curve in a coordinate system somehow without qwt?

    teele
    Last edited by teele; 28th March 2012 at 07:19. Reason: misspelling

  6. #6
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,012 Times in 4,791 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: Qt on Ubuntu 10.04 from Ubuntu packages?

    Quote Originally Posted by teele View Post
    I just tried

    apt-get install libqwt-dev

    but it didn't give a working system. In fact, the entire qt was confused after that.
    Apparently your system was already broken before issuing this command.

    Could I get an animated sine curve in a coordinate system somehow without qwt?
    You can always draw it yourself. However it won't repair your broken system installation
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


Similar Threads

  1. Problems in Ubuntu 10.10
    By gmiller39 in forum Installation and Deployment
    Replies: 1
    Last Post: 27th November 2010, 02:26
  2. Ubuntu 10.04 and Qt 4.62
    By fulin in forum Newbie
    Replies: 2
    Last Post: 25th May 2010, 16:42
  3. How to on Ubuntu?
    By prchakal in forum Qt Programming
    Replies: 3
    Last Post: 10th March 2010, 06:11
  4. Qt in Ubuntu
    By impeteperry in forum General Programming
    Replies: 4
    Last Post: 30th November 2008, 01:16
  5. Qt3 Installation on Ubuntu 7.04
    By jflowers in forum Installation and Deployment
    Replies: 1
    Last Post: 16th January 2008, 19:20

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.