Results 1 to 1 of 1

Thread: DBUS signals are delayed when process is started at boot

  1. #1
    Join Date
    Oct 2009

    Default DBUS signals are delayed when process is started at boot

    I am having a strange problem trying to get a small program running at boottime before any user has logged in.

    I have used different methods of running the program at boot and nothing has helped me yet! Anyway, I have a small Qt program that communicates with a different program via DBUS (systembus). Currently the program is started with upstart and registers the service etc. fine on the systembus. I can also call different methods of the program using "qdbus --system", these methods return immediately with correct return values. I have set the Qt program to send a DBUS signal every second. when monitoring this with dbus-monitor i only see a signal being passed every 2-5 seconds but when I kill the program and log in as a user (root) the program sends its signals just fine (every second).

    i have spent a few hours trying to find the cause of this problem and it looks as if the speed of the systembus is slow when the process is not started as a user, i can see the data being sent as soon as the signal is emmited but it takes a very long time for the signal to be fully sent on the bus. I have set 100 Bytes of data to be emitted with the signal and when the process is started as a user the data is sent immediatly while if the process is started at boot the sending of the data takes about 8-10 seconds.

    How is this possible? I want the program sending the signals to run when the computer boots and have another user application connected to the signals to take action when the signal is received.

    I have tried to run the program as an upstart job, using the init.d way and the normal rc.local way but all with the same result.

    Do I have to have a user logged in for this to work?


    Last edited by sisco; 9th January 2013 at 21:13.

Similar Threads

  1. Kill a Process started with Qprocess ??
    By jesse_mark in forum Newbie
    Replies: 9
    Last Post: 29th November 2012, 23:38
  2. The process could not be started! Error
    By jujose in forum Installation and Deployment
    Replies: 3
    Last Post: 27th February 2010, 17:25
  3. Qt Creator: The process could not be started!
    By AlphaWolf in forum Qt Programming
    Replies: 5
    Last Post: 24th September 2009, 03:31
  4. Signals are delayed on X11?
    By Cruz in forum Qt Programming
    Replies: 13
    Last Post: 18th February 2009, 12:59
  5. Replies: 2
    Last Post: 30th March 2007, 08:10

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.