I ran into this error message yesterday, but found no related solution on the whole wide web.. Luckily, since then, I have one.

The problem
When building a debug build in Qt Creator, and starting a debug session, an error message box appears with the following text: "PC register is not available" Hitting ok closes the box, the debug session seems to run, but nothing is happening, and you have to close Creator to stop the debug process.

A solution
I don't say this is the solution, but this is a possible reason for the error.
In short: use the matching debugger for the GCC toolchain you selected
First, check the auto-detected tool-chain options in Options ->Build & Run -> Tool Chains. If the compiler path points to a system compiler (eg. /usr/bin/g++), but the Debugger is the SDK-bundled one (eg. QtSDK/debugger/Desktop/bin/gdb), then you're in trouble. The bundled tool-chain is most likely 32bit (x86), and if you're on a 64bit (x86_64) system, this will cause an obvious incompatibility, which may result in the error above.
As the auto-detected tool-chains are not modifiable, create a new tool-chain with the matching tools. For example /usr/bin/g++ for the compiler (you can freely chose the ABI), and /usr/bin/gdb for the debugger. Or chose the SDK version for both.
Also, in the project build settings, the best practice to use the system tool-chain with the system Qt version or the SDK tool-chain with the bundled SDK Qt version.

In my Creator settings, the auto-detected tool-chain used the system GCC (x86_64), and the SDK gdb (x86), and this created the incompatibility. I had to manually create a new tool-chain with the correct settings.

I just wanted to share the solution.