Results 1 to 4 of 4

Thread: /usr/bin/ld: cannot find -lQt5WebKit, and similar errors

  1. #1
    Join Date
    Feb 2010
    Posts
    21
    Thanks
    3
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default /usr/bin/ld: cannot find -lQt5WebKit, and similar errors

    Hi...

    Not sure if this question belongs here...

    I find myself in this situation:

    Since my software must run on Linux/Windows I download the lastest version offline for Windows, Qt 5.1.x

    My current development environment is Linux with Qt 4.8

    I start the migration of the code, Install a virtual machine with ubuntu, full updates, and install the corresponding Qt 5 version (qt-linux-opensource-5.1.1-x86_64-offline.run)
    So both versions, can be build with the same versions, and not live in a conditional programming because the versions.

    Copy the project to this virtual machine. Resolve some issues related to a migration from 4.x to 5.x versions.

    In the last step of build, give me this errors:

    /usr/bin/ld: skipping incompatible /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5WebKit.so when searching for -lQt5WebKit
    /usr/bin/ld: cannot find -lQt5WebKit
    /usr/bin/ld: skipping incompatible /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5Widgets.so when searching for -lQt5Widgets
    /usr/bin/ld: cannot find -lQt5Widgets
    /usr/bin/ld: skipping incompatible /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5Xml.so when searching for -lQt5Xml
    /usr/bin/ld: cannot find -lQt5Xml
    /usr/bin/ld: skipping incompatible /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5Network.so when searching for -lQt5Network
    /usr/bin/ld: cannot find -lQt5Network
    /usr/bin/ld: skipping incompatible /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5Gui.so when searching for -lQt5Gui
    /usr/bin/ld: cannot find -lQt5Gui
    /usr/bin/ld: skipping incompatible /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5Core.so when searching for -lQt5Core
    /usr/bin/ld: cannot find -lQt5Core
    collect2: error: ld returned 1 exit status


    I solve a "smilar" problem: /usr/bin/ld: cannot find -lGL
    just running: sudo apt-get install libglu1-mesa-dev
    and add to the pro file LIBS += -lGL

    My curren pro file has this

    QT += network \
    webkit \
    xml \
    widgets

    Any idea, how to solve this, and what is causing this problem?


    Thanks in advance...

  2. #2
    Join Date
    Jan 2006
    Location
    Warsaw, Poland
    Posts
    33,364
    Thanks
    3
    Thanked 5,014 Times in 4,792 Posts
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows Android Maemo/MeeGo
    Wiki edits
    10

    Default Re: /usr/bin/ld: cannot find -lQt5WebKit, and similar errors

    Show us the result of the following two commands:

    $ file /home/xxxxx/Qt5.1.1/5.1.1/gcc/lib/libQt5Core.so
    $ uname -a
    Your biological and technological distinctiveness will be added to our own. Resistance is futile.

    Please ask Qt related questions on the forum and not using private messages or visitor messages.


  3. #3
    Join Date
    Feb 2010
    Posts
    21
    Thanks
    3
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: /usr/bin/ld: cannot find -lQt5WebKit, and similar errors

    Sure... thanks

    file /home/xxxxx/Qt5.1.1/5.1.1/gcc_64/lib/libQt5Core.so
    /home/xxxxx/Qt5.1.1/5.1.1/gcc_64/lib/libQt5Core.so: symbolic link to `libQt5Core.so.5.1.1'

    uname -a
    Linux test-box 3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    Edit:

    I'm installing a new machine (Ubuntu 64 / Same Qt installer/64). Since I want to check if this is a weird case or something I can "reproduce".
    Last edited by nomadscarecrow; 20th September 2013 at 20:37. Reason: updated contents

  4. #4
    Join Date
    Feb 2010
    Posts
    21
    Thanks
    3
    Thanked 1 Time in 1 Post
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: /usr/bin/ld: cannot find -lQt5WebKit, and similar errors

    Well, I setup a new virtual machine, and fortunately the problem is gone. :P

    Thanks

Similar Threads

  1. Looking for similar structure in QT
    By tarakm87 in forum Newbie
    Replies: 1
    Last Post: 22nd March 2013, 16:11
  2. Replies: 1
    Last Post: 28th May 2012, 15:06
  3. Compiling errors - can't find the libraries
    By magelet in forum Newbie
    Replies: 7
    Last Post: 24th May 2010, 08:24
  4. Something similar to WS_GROUP in Qt?
    By zoeker in forum Qt Programming
    Replies: 1
    Last Post: 27th June 2008, 22:22
  5. are they similar in performance ?
    By Gopala Krishna in forum General Programming
    Replies: 3
    Last Post: 12th January 2008, 19:05

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.