Results 1 to 15 of 15

Thread: I am trying to install qtspeech

  1. #1
    Join Date
    Apr 2013
    Location
    San Jose Ca USA
    Posts
    8
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default I am trying to install qtspeech

    I am trying to install qtspeech

    I am on linux mint 13 . And qt 5.02.

    I followed the install instructions and the script had errors when run.

    anybody got this to work?

    below is part of the install text.

    ---
    QtSpeech uses qmake to build itself as static library.
    qmake is part of a Qt distribution. For Unix Festival
    is required as TTS engine.

    Building QtSpeech
    ==========================

    A) Unix
    --------

    sh get-festival.sh
    qmake QtSpeech.pro
    make
    ---



    THANKS !

  2. #2
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,679
    Thanks
    13
    Thanked 1,596 Times in 1,524 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: I am trying to install qtspeech

    I followed the install instructions and the script had errors when run.
    What a shame you didn't share them with us.

    anybody got this to work?
    Yes, more than likely.

    speech_tools and festival both fail to build for me (nothin to drastic to fix). Perhaps there's a more recent version of each that is fixed or help in the mailing lists for those non-Qt packages.
    I can see from the repository that there is no QtSpeech.pro file but there are other, obvious equivalents.

  3. #3
    Join Date
    Apr 2013
    Location
    San Jose Ca USA
    Posts
    8
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: I am trying to install qtspeech

    Well ... thanks for your reply ...

    the section of code with the error was ...

    sh get-festival.sh <----------------- HERE

    lots of errors ... I suppose it was download error from missing files.

    I was not sure from what directory to run this script ... home? qt directory ? does it matter?

    so like i said ... i download festival and tools from the apt-get process and ... I believe i have them files

    SO ... anybody got qtspeech to WORK on linux ???

    thx

  4. #4
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,679
    Thanks
    13
    Thanked 1,596 Times in 1,524 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: I am trying to install qtspeech

    Quote Originally Posted by Dodeca View Post

    sh get-festival.sh <----------------- HERE

    lots of errors ... I suppose it was download error from missing files.
    No they are compiler errors from trying to build the files it has downloaded. Both sets of source code fail to build. The errors are fairly easy to fix but they have nothing to do with Qt.

    I was not sure from what directory to run this script ... home? qt directory ? does it matter?
    You should run the get-festival.sh script from the directory containing the script. It creates a sub directory "festival" in which it works, downloads speech_tools, builds it (fails), downloads festival, builds it (fails). Read the get-festival.sh file for the steps.

    so like i said ... i download festival and tools from the apt-get process and ... I believe i have them files
    The get-festival.sh script is about fetching and building a local copy of these tools. Apt-get is not used.
    If you already have festival installed using your system tools then you may be able to skip get-festival.sh entirely and build qt-speech itself bearing in mind that the pro file is not named as in the instructions and that it may be hard coded to use the local copy of festival you have skipped downloading (hence requiring modification)

  5. #5
    Join Date
    Apr 2013
    Location
    San Jose Ca USA
    Posts
    8
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: I am trying to install qtspeech

    Thanks for your quick reply !

    It seems by your reply ... you have personally got the thing to work?

    GOOD FOR YOU !

    The errors are fairly easy to fix but they have nothing to do with Qt
    Well it's good the code is easy for you to understand ...

    So ... why can't you tell me the answer you know all to well ... instead of NOT telling me?

    I don't get it ?

    me

  6. #6
    Join Date
    Apr 2013
    Location
    San Jose Ca USA
    Posts
    8
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: I am trying to install qtspeech

    You are right ... the code fails here ...

    #!/bin/sh
    mkdir -p festival
    cd festival
    curl http://www.cstr.ed.ac.uk/downloads/f...release.tar.gz -o speech_tools.tar.gz
    tar -zxf speech_tools.tar.gz
    cd speech_tools
    ./configure
    make <---------------------------------------- HERE

    and not the download !


    me

  7. #7
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,679
    Thanks
    13
    Thanked 1,596 Times in 1,524 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: I am trying to install qtspeech

    No, I have not got it to work. I downloaded qt-speech, read and ran the shell script and scanned the error messages. The compilation errors contained sufficient information to correct the problem (the GCC error actually tells you exactly what to do for at least the first few) so I assumed that it was not a lost cause. None of this is Qt specific. The best people to talk to about compilation problems in the festival components is the the people that wrote/use it.

    You since provided extra information that indicated you had obtained festival libraries from your distro repositories. In that case you can skip the whole step of running the script and building festival because someone else has done the work for you. You then proceed to following the rest of your INSTALL instructions. I have pointed out the obvious error there but have not proceeded to try and build it.

  8. #8
    Join Date
    Apr 2013
    Location
    San Jose Ca USA
    Posts
    8
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: I am trying to install qtspeech

    Well ... I believe my best plan is to find someone who has it working and willing to share.

    thanks for you input

    me

  9. #9
    Join Date
    Jul 2013
    Posts
    3
    Thanks
    3
    Qt products
    Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Maemo/MeeGo

    Default Re: I am trying to install qtspeech

    i get the following error when build QtSpeech application on ubuntu. what could be the reason?
    :-1: error: cannot find -lasound
    :-1: error: collect2: ld returned 1 exit status

  10. #10
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,546 Times in 1,496 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: I am trying to install qtspeech

    Package libasound2-dev not installed perhaps?

    Cheers,
    _

  11. The following user says thank you to anda_skoa for this useful post:

    togvn202 (7th February 2014)

  12. #11
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,679
    Thanks
    13
    Thanked 1,596 Times in 1,524 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: I am trying to install qtspeech

    As the error message says, the library named 'asound' is not on your system. At a guess it is part of the ALSA libraries.

  13. The following user says thank you to ChrisW67 for this useful post:

    togvn202 (7th February 2014)

  14. #12
    Join Date
    Jul 2013
    Posts
    3
    Thanks
    3
    Qt products
    Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Maemo/MeeGo

    Default Re: I am trying to install qtspeech

    after i install package libasound2-dev, and recompline QtSpeech app, i get the following error:

    editline.c: (.text+0x7824): undefined reference to `tgetent'
    editline.c: (.text+0x7847): undefined reference to `tgetstr'
    editline.c: (.text+0x794a): undefined reference to `tgetnum'
    How to solve this problem?

  15. #13
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,679
    Thanks
    13
    Thanked 1,596 Times in 1,524 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: I am trying to install qtspeech

    The three functions are part of a Curses library that is missing. You might need Ncurses available.
    "We can't solve problems by using the same kind of thinking we used when we created them." -- Einstein
    If you are posting code then please use [code] [/code] tags around it - makes addressing the problem easier.

  16. The following user says thank you to ChrisW67 for this useful post:

    togvn202 (8th February 2014)

  17. #14
    Join Date
    Jul 2013
    Posts
    3
    Thanks
    3
    Qt products
    Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Maemo/MeeGo

    Default Re: I am trying to install qtspeech

    Quote Originally Posted by ChrisW67 View Post
    The three functions are part of a Curses library that is missing. You might need Ncurses available.
    Thanks for your support but i have already installed Curses library for Ubuntu but this error still occurs when i rebuild Qt apps. Besides, I tried to remove and re-install this library for a several times for sure. This error really makes me confused, Can you tell me the more detailed way to make it go right.
    the error here:
    editline.c: (.text+0x7847): undefined reference to `tgetstr'
    editline.c: (.text+0x7860): undefined reference to `tgetstr'
    editline.c: (.text+0x7879): undefined reference to `tgetstr'
    editline.c: (.text+0x7892): undefined reference to `tgetstr'
    editline.c: (.text+0x7912): undefined reference to `tgetstr'
    editline.c: (.text+0x7939): undefined reference to `tgetnum'
    editline.c: (.text+0x794a): undefined reference to `tgetnum'
    editline.c: (.text+0x7a44): undefined reference to `tgetstr'
    collect2: ld returned 1 exit status
    make: *** [test] Error 1
    11:44:34: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project test (target: Desktop)
    When executing step 'Make'
    Last edited by togvn202; 10th February 2014 at 10:13.

  18. #15
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,679
    Thanks
    13
    Thanked 1,596 Times in 1,524 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: I am trying to install qtspeech

    The functions are from Curses.
    Curses is installed on the system.
    The linker cannot find them.
    Ergo, the linker is looking in the wrong place, being told to look somewhere specific that's incorrect, or not looking at all.

    Look at the entire linker command and entire linker message stream for clues.

    This really has nothing to do with Qt.

Similar Threads

  1. Replies: 0
    Last Post: 17th November 2011, 14:35
  2. Replies: 6
    Last Post: 14th March 2011, 00:49
  3. Replies: 4
    Last Post: 18th April 2010, 01:37
  4. How install fonts with make install
    By jiveaxe in forum Qt Programming
    Replies: 1
    Last Post: 2nd January 2008, 20:38
  5. "make install" doesn't install binary
    By jiveaxe in forum Newbie
    Replies: 2
    Last Post: 2nd January 2008, 13:00

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.