Results 1 to 1 of 1

Thread: -IGL error in CentOS 6

  1. #1
    Join Date
    Sep 2011
    Location
    Bangalore
    Posts
    248
    Thanks
    91
    Thanked 16 Times in 16 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Windows

    Default Re: -IGL error in CentOS 6

    I just installed Qt in CentOS 6 and when I try to compile a test project which has just QWidget to be displayed, it's throwing this error

    OS: CentOS 6
    Qt Version: Qt 5.2.1 (GCC 4.6.1, 32 bit)
    Qt Code:
    1. error: cannot find -lGL
    To copy to clipboard, switch view to plain text mode 

    Kindly help me fix this issue.

    Thank you.


    Added after 22 minutes:


    ----- Solution ------

    I found the solution. Installing the following packages worked!

    Qt Code:
    1. yum install mesa-libGL-devel mesa-libGLU-devel
    To copy to clipboard, switch view to plain text mode 

    Thank you.
    Last edited by rawfool; 20th February 2014 at 12:58.

Similar Threads

  1. How to Install Qt 5 and Qwt on CentOS 6
    By lightdesign84 in forum Installation and Deployment
    Replies: 0
    Last Post: 14th January 2014, 19:40
  2. How to install 4.8 on CentOS 6
    By Markus in forum Installation and Deployment
    Replies: 2
    Last Post: 8th October 2013, 23:30
  3. How to run my Qt programme on an old CentOS
    By Patrick Sorcery in forum Installation and Deployment
    Replies: 0
    Last Post: 3rd January 2011, 05:55
  4. Using QT in CentOS
    By vishakvkurup in forum Qt Programming
    Replies: 7
    Last Post: 15th January 2008, 22:01
  5. Qt4 on Centos 64 m/c
    By a_m_mukul in forum Qt Programming
    Replies: 2
    Last Post: 22nd November 2007, 15:22

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.