Results 1 to 1 of 1

Thread: Trying to add Kit fails

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Nov 2009
    Laval, France
    Thanked 2 Times in 2 Posts
    Qt products

    Default Trying to add Kit fails

    I had a QtCreator that ran with MinGW (I dowloaded the installer that did this). In a bid to fix a bug which seemed to be dependent on the version of Qt I decided to upgrade to Qt 5.3.1.
    I uninstalled my previous versions of Qt (because the installed told me I already had a c:\Qt folder and this was preventing me from installing Qt).
    Then I dowloaded the "default version" of Qt. It turned out this was based on MSVC (which is installed on my PC, 2008 professional and some more recent Express versions).

    So I installed that, it seemed to install, but I could not debug anything like I used to. I got that nasty "No debugger set up" message. I tried looking around on forums and got the idea
    I had to look at a page on Microsoft's site to get the debugger. You mean to say that the Qt installer could not do this for me? Anyway looking at that site I was confused, do
    I need to have a licence for a professional version of MSVC? Certainly I could not rely on my VC 2008 compiler because I'm trying to use C++2011 features.

    Luckily I have another PC, on which I installed Qt 5.3.1 based on MingW. I can do some debugging there.
    But I thought I could possibly add kits, after all I do have directories named c:\MingW and c:\MingW64. Somehow their presence does not seem to be detected.
    I wondered if this is due to the registry being overzealously cleaned by the Qt uninstaller.
    I had a try at installing a kit manually with Qt Creator's Tools > OptionAdd. I was just guessing here: I entered g++.exe in Compiler Path
    and did not have a clue about what platform codegen flags I should add.
    Anyway eventually I had MingW in the list of Autodetected Compilers inside Tools>Options>compilers.
    But suppose I create a new project, then there is a Kit Selection dialog that appears. It doesnt propose a MingW compiler at all.
    What's more, I'm supposing that MingW64 is a separate compiler. If I try to add that manually I get a message that it has already been installed, thankyou you very much, so please dont try this again. But it certainly does not appear in the list of available compilers, let alone in the compiler kits.

    So you see my main goal is to be able to use the debugger. I dont care too much if the debugger is for MSV, but the documentation and environment is not really friendly, so I need a bit of help.

    Having tried to install the Windows 7 developement SDK, it failed. The workarounds are too complex. I will uninstall Qt Creator made for MSVC and use the MingW version.
    Last edited by feraudyh; 30th June 2014 at 14:00.

Similar Threads

  1. Dequeue fails
    By saman_artorious in forum Qt Programming
    Replies: 8
    Last Post: 21st April 2013, 14:04
  2. Qt 4.6.2 Mac Installation fails .
    By nikhil in forum Installation and Deployment
    Replies: 1
    Last Post: 6th October 2012, 11:45
  3. Replies: 2
    Last Post: 13th December 2011, 16:44
  4. Compiling of Qt4.6 fails
    By Wonko in forum Installation and Deployment
    Replies: 5
    Last Post: 18th February 2010, 16:18
  5. qt 4.5.2: make fails
    By unknown in forum Installation and Deployment
    Replies: 13
    Last Post: 3rd September 2009, 16:53

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.