Results 1 to 2 of 2

Thread: QWebView::Load https problem

  1. #1
    Join Date
    Jan 2015
    Posts
    1
    Qt products
    Qt4
    Platforms
    MacOS X Windows

    Post QWebView::Load https problem

    I have a URL,

    https://www.flickr.com/

    I am calling QWebView::load(); To show this page.
    But this page load failed.

  2. #2
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,626
    Thanks
    13
    Thanked 1,592 Times in 1,520 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: QWebView::Load https problem

    I assume you have not installed a version of the third-party OpenSSL libraries required to support HTTPS. One place you can get pre-built libraries for Windows is http://slproweb.com/products/Win32OpenSSL.html. For OS X there might be an equivalent binary distribution. You could build OpenSSL for yourself.

    See http://doc.qt.io/qt-5/build-sources....1-0-0-or-later

Similar Threads

  1. Use of QWebView to browse "https" secure sites
    By grigoryan_hayk in forum Qt Programming
    Replies: 7
    Last Post: 21st September 2016, 21:16
  2. QWebView load function
    By zgulser in forum Newbie
    Replies: 1
    Last Post: 16th August 2012, 19:52
  3. QWebView + HTTPS with certificate example
    By kylls in forum Qt Programming
    Replies: 1
    Last Post: 16th March 2011, 06:07
  4. QwebView unable to load
    By asmncl in forum Qt Programming
    Replies: 2
    Last Post: 11th February 2011, 06:00
  5. QWebView::Load problem
    By yogeshgokul in forum Qt Programming
    Replies: 2
    Last Post: 3rd December 2008, 10:28

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.