Results 1 to 3 of 3

Thread: QMediaPlayer does not playe audio with high bitrate, why?

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Feb 2012
    Location
    Stuttgart / Germany
    Posts
    35
    Thanks
    6
    Qt products
    Qt3 Qt4
    Platforms
    Windows

    Default QMediaPlayer does not playe audio with high bitrate, why?

    Hello, I am using Qt5.4 because of QMediaPlayer, I started with the player example and I made some modifications to add the features I wanted. It is everything working fine, but let it running and testing I realized that some of my mp3's did not play, the player jump them and plays another one. I checked some of the files and the only difference I found it is the audio bitrate. The player jumps files with audio bitrate of 192kbit/s or 128kbit/s. Why does it happen? Anyone had the same problem than I?

    Thanks in advance.
    Best Regards.

  2. #2
    Join Date
    Feb 2012
    Location
    Stuttgart / Germany
    Posts
    35
    Thanks
    6
    Qt products
    Qt3 Qt4
    Platforms
    Windows

    Default Re: QMediaPlayer does not playe audio with high bitrate, why?

    If anyone has the same problem, it was not related to the audio bitrate. It was related to this bug: http://quia.cf/orange/pooxy4/nph-pox...TMOBILITY-1461

    It was missing the codecs. Not is playing all.

  3. #3
    Join Date
    Mar 2009
    Location
    Brisbane, Australia
    Posts
    7,734
    Thanks
    13
    Thanked 1,610 Times in 1,537 Posts
    Qt products
    Qt4 Qt5
    Platforms
    Unix/X11 Windows
    Wiki edits
    17

    Default Re: QMediaPlayer does not playe audio with high bitrate, why?


Similar Threads

  1. Get QAudioBuffer from QMediaPLayer
    By azazaz in forum Qt Programming
    Replies: 2
    Last Post: 18th February 2014, 05:10
  2. Playing MP4 and FLV with QMediaPlayer
    By JasonKretzer in forum Newbie
    Replies: 2
    Last Post: 12th September 2013, 21:58
  3. QMediaPlayer problems
    By alenn.masic in forum Qt Programming
    Replies: 1
    Last Post: 25th February 2013, 15:32
  4. QMediaPlayer: MP4 file with AAC audio format
    By ollerei in forum Qt Programming
    Replies: 1
    Last Post: 12th February 2013, 02:51
  5. Phonon - audio-output-problem and high latency
    By nearlyNERD in forum Qt Programming
    Replies: 3
    Last Post: 27th June 2012, 21:17

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.