Results 1 to 3 of 3

Thread: Qt 5.4 app unable to start without any error in Ubuntu 14.04

  1. #1
    Join Date
    Jun 2014
    Posts
    24
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Android Maemo/MeeGo

    Default Qt 5.4 app unable to start without any error in Ubuntu 14.04

    I made deb file with QT 5.4 by adding PrintSupport, OpenGL Qt5 module in cmake list file and installed the deb into my machine.

    Qt 5.4 app executable unable to start and not giving any error ( I think it crashes) but when I replace the same executable with execubale which I made from Qt creator then it is working.

    What I think is that Qt creator build taking reference of the QT5.4 installation and deb build taking the reference from the my machine's installed .so files. that Is why I am getting this issue.

    If any one has idea about the issue then please suggest me to resolve the issue.

    Thanks.

  2. #2
    Join Date
    Jun 2014
    Posts
    24
    Qt products
    Qt3 Qt4 Qt5 Qt/Embedded
    Platforms
    MacOS X Unix/X11 Windows Symbian S60 Android Maemo/MeeGo

    Default Re: Qt 5.4 app unable to start without any error in Ubuntu 14.04

    Adding some more info regarding the same issue below.

    I am able to make deb file of Qt 5.2.1 app but not Qt 5.4 app in Ubuntu 14.04 LTS, 64 bit.

    I have seen that Qt .so files present at the path /usr/lib/x86_64-linux-gnu/ are Qt 5.2.1 compatible not the Qt 5.4 compatible.

    So I just want to know that which Qt version compatible .so files come with default Ubuntu 14.04 LTS Trusry and if it not Qt 5.4 compatible then how can I make it Qt 5.4 compatible ?

  3. #3
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,545 Times in 1,495 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: Qt 5.4 app unable to start without any error in Ubuntu 14.04

    If the system comes with an older version of Qt, you ship Qt with your application.

    Cheers,
    _

Similar Threads

  1. Unable to make deb file of Qt 5.4 app in Ubuntu 14.04
    By manojpatidar in forum Installation and Deployment
    Replies: 10
    Last Post: 25th February 2015, 12:38
  2. Unable to start linux process by Qt
    By karankumar1609 in forum Qt Programming
    Replies: 3
    Last Post: 19th December 2013, 10:34
  3. QProcess : unable to start sis file
    By javed_alam786 in forum Qt for Embedded and Mobile
    Replies: 6
    Last Post: 26th August 2011, 13:42
  4. Replies: 9
    Last Post: 15th April 2011, 07:51
  5. Qt Creator Not able to start qt debugger in Ubuntu
    By bakul2331 in forum Qt Tools
    Replies: 3
    Last Post: 15th July 2010, 09:19

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.