Results 1 to 3 of 3

Thread: LD_DEBUG=all cat

  1. #1
    Join Date
    Oct 2015
    Posts
    27
    Qt products
    Qt5 Qt/Embedded
    Platforms
    Unix/X11

    Default LD_DEBUG=all cat

    After cross compilng Qt creator executable , i try to execute on Grayhill 270 ARM board. The problem while executing is ,

    1. if i run my application like "./myApp -qws" there is no error but application not displaying anything on the board
    2. If i run my application without QWS like "./MyApp -platform eglfs " it is giving the error like "QWSSocket::connectToLocalFile could not connect:: Connection refused"
    3. If i go to Help-->About Qt Creator , a pop up comes like " Qt Creator 3.4.2 (opensource) Based on Qt 5.5.0 (GCC 4.9.1 20140922 (Red Hat 4.9.1-10), 64 bit) " . Is this Qt5 or Qt3
    4. After running the application like "./MyApp -platform eglfs " , i run LD_DEBUG=all cat now a list of lines coming like "file=libc.so.6 [0]; needed by cat [0] find library=libc.so.6 [0]; searching" . Is this lists releted to the application "./MyApp -platform eglfs"

  2. #2
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,546 Times in 1,496 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: LD_DEBUG=all cat

    Quote Originally Posted by shivcena View Post
    After cross compilng Qt creator executable , i try to execute on Grayhill 270 ARM board. The problem while executing is ,

    1. if i run my application like "./myApp -qws" there is no error but application not displaying anything on the board
    That is a contradition. The executable for Qt Creator is called qtcreator, not "myApp"
    So either you are launching the wrong example or you are not cross compiling Qt Creator.

    Quote Originally Posted by shivcena View Post
    3. If i go to Help-->About Qt Creator , a pop up comes like " Qt Creator 3.4.2 (opensource) Based on Qt 5.5.0 (GCC 4.9.1 20140922 (Red Hat 4.9.1-10), 64 bit) " . Is this Qt5 or Qt3
    Based on Qt 5.5.0

    Quote Originally Posted by shivcena View Post
    4. After running the application like "./MyApp -platform eglfs " , i run LD_DEBUG=all cat now a list of lines coming like "file=libc.so.6 [0]; needed by cat [0] find library=libc.so.6 [0]; searching" . Is this lists releted to the application "./MyApp -platform eglfs"
    Well, is your application executable called "cat"?
    Then yes, this is relevant. If not, then obviously no.

    Cheers,
    _

  3. #3
    Join Date
    Oct 2015
    Posts
    27
    Qt products
    Qt5 Qt/Embedded
    Platforms
    Unix/X11

    Default Re: LD_DEBUG=all cat

    Well, is your application executable called "cat"?
    Then yes, this is relevant. If not, then obviously no


    1) i tried like LD_DEBUG=all ./myApp
    where "myApp" is the name of the executable. now some lines are continuously coming but related to QT executable only. Can i track what is the problem exactly using this lines

    2) At the end of debug i found like "symbol=_ZN15QAbstractSocket5errorENS_11SocketErro rE;" . What is this ? how to resolve this?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.