Results 1 to 4 of 4

Thread: Qt-4.1 and FC4 with make

  1. #1
    Join Date
    Jan 2006
    Posts
    185
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Qt-4.1 and FC4 with make

    I am trying to install Qt-4.1 in Fedora Core 4.

    The problem I have is that after typing "./configure" I receive this message:

    Creating qmake. Please wait...
    g++ -c -o project.o -pipe -DQMAKE_OPENSOURCE_EDITION -g -I. -Igenerators -Igenerators/unix -Igenerators/win32 -Igenerators/mac -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/src/corelib/arch/generic -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/include -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/include/QtCore -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/include -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/include/QtCore -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/src/corelib/global -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_BUILD_QMAKE -DQT_NO_COMPRESS -I/home/santiago/programs/qt-x11-opensource-src-4.1.0/mkspecs/linux-g++ -DHAVE_QCONFIG_CPP -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT project.cpp
    gmake: g++: Command not found
    gmake: *** [project.o] Error 127


    1. I do not want to use "gmake". I would like to compile with "make".
    2. I have "gcc" installed in my computer. What is the deal with g++ ?

  2. #2
    Join Date
    Feb 2006
    Location
    Kirovohrad, Ukraine
    Posts
    72
    Thanks
    1
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Qt-4.1 and FC4 with make

    Quote Originally Posted by probine
    1. I do not want to use "gmake". I would like to compile with "make".
    You are using Linux => Linux uses GNU environment => gmake stands for GNU make => make is just an alias (read symlink) to gmake (or vice versa).
    Quote Originally Posted by probine
    2. I have "gcc" installed in my computer. What is the deal with g++ ?
    g++ is GNU C++ compiler. You should have installed both gcc-something.rpm and g++-something.rpm. I don't actually know the right packages name for FC

  3. #3
    Join Date
    Jan 2006
    Location
    Athens - Greece
    Posts
    219
    Thanks
    3
    Thanked 1 Time in 1 Post
    Qt products
    Qt3 Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Qt-4.1 and FC4 with make

    Quote Originally Posted by probine
    1. I do not want to use "gmake". I would like to compile with "make".
    2. I have "gcc" installed in my computer. What is the deal with g++ ?
    1. You already do don't worry.
    2. The deal is that you have to install it because you won't be able to compile any c++ programs.

  4. #4

    Default Re: Qt-4.1 and FC4 with make

    You will need to install gcc-c++:

    yum -y install gcc-c++
    I had this same problem with a CentOS5 installation and fund a fix for it. I thought I would post my fix for the issue even though this thread is quite old.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.