Results 1 to 5 of 5

Thread: strange behavior of qt 5.4

  1. #1
    Join Date
    Oct 2006
    Posts
    6
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default strange behavior of qt 5.4

    Hi all, I'm writing a program that reads data from web pages and stores them in a sqlite db.
    Senzanome.jpgSuddenly, now, if I try to go to the program in debug mode, I get a segmentation fault notification.

    Senzanome3.png

    Senzanome2.png
    If I run normally, it works!

    Can someone explain this behavior?
    Thank you!!

  2. #2
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,418
    Thanks
    37
    Thanked 1,545 Times in 1,495 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: strange behavior of qt 5.4

    You should probably debug the crash :-)

    Cheers,
    _

  3. #3
    Join Date
    Jan 2008
    Location
    Alameda, CA, USA
    Posts
    5,110
    Thanks
    290
    Thanked 844 Times in 831 Posts
    Qt products
    Qt5
    Platforms
    Windows

    Default Re: strange behavior of qt 5.4

    Can someone explain this behavior?
    Yes. Your program has a bug in it.

  4. #4
    Join Date
    Oct 2006
    Posts
    6
    Thanks
    2
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: strange behavior of qt 5.4

    Maybe program has a bug, but on another PC, in the same conditions, it works in debug mode and in release mode!
    What in the system can affect it?

  5. #5
    Join Date
    Jan 2008
    Location
    Alameda, CA, USA
    Posts
    5,110
    Thanks
    290
    Thanked 844 Times in 831 Posts
    Qt products
    Qt5
    Platforms
    Windows

    Default Re: strange behavior of qt 5.4

    What in the system can affect it?
    Do you know how to use the debugger? Run your code in debug mode, wait for it to crash, then examine the call stack to see where it crashed, then look at the code and figure out why it crashed.

    Or would you prefer for us to make random guesses based on a few screenshots? It's a segmentation fault, which is most commonly caused by a bad pointer - uninitialized, pointing to a bad location, already deleted, NULL, or any one of a bunch of reasons. You have a bug in your code which apparently only occurs under certain circumstances, and the remedy is to do what all of the rest of us do - debug the program.

Similar Threads

  1. Qt process strange behavior
    By rspock in forum Newbie
    Replies: 5
    Last Post: 15th March 2013, 17:11
  2. QAudioInput example strange behavior
    By m15ch4 in forum Qt Programming
    Replies: 0
    Last Post: 13th August 2010, 06:55
  3. Qt Creator Strange behavior of GDB in Creator 1.3
    By rayjc in forum Qt Tools
    Replies: 1
    Last Post: 11th March 2010, 21:42
  4. Strange behavior of QSqlTableModel
    By venomj in forum Qt Programming
    Replies: 0
    Last Post: 13th January 2010, 03:29
  5. QComboBox strange behavior
    By Antebios in forum Newbie
    Replies: 2
    Last Post: 31st March 2009, 23:50

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.