Results 1 to 2 of 2

Thread: Qt Fake Vim

  1. #1
    Join Date
    Oct 2015
    Posts
    1
    Qt products
    Qt5
    Platforms
    Windows

    Default Qt Fake Vim

    I'm just starting to use Qt.

    I've been using vim for quite a while and so it's pretty much a must for any IDE that I use. I've enable Fake Vim in Qt Creator, but I've noticed that whenever I use the j or k keys to move the cursor up or down, the cursor jumps up to the top of the file. Also there is this red box that appears at the bottom panel saying "Recursive Mapping".

    As I'm fairly new to qt, I think it is very likely that is just something simple that I'm messing up.

  2. #2
    Join Date
    May 2008
    Posts
    155
    Thanked 15 Times in 13 Posts
    Qt products
    Qt4
    Platforms
    Unix/X11

    Default Re: Qt Fake Vim

    Try to switch off reading your .vimrc settings in Tools->Options->FakeVim. Then look what's in your .vimrc and remove/workaround anything that looks like a recursive mapping.

Similar Threads

  1. fake vim change block
    By vgrunert in forum Qt Tools
    Replies: 0
    Last Post: 4th May 2015, 09:59
  2. how to generate a fake Alt+Tab event
    By Soumya Somasekhar Ram in forum Qt Programming
    Replies: 3
    Last Post: 18th September 2013, 09:34
  3. Qt Creator Question about Fake Vim in QtCreator 1.3.1 !
    By qt_chan in forum Qt Tools
    Replies: 3
    Last Post: 11th November 2011, 00:08
  4. Fake key events
    By Bolick in forum Qt Programming
    Replies: 4
    Last Post: 21st August 2009, 05:29

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.