Results 1 to 4 of 4

Thread: Compatibility Windows 10 - Qt 4.8.6

  1. #1
    Join Date
    Dec 2015
    Posts
    7
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Compatibility Windows 10 - Qt 4.8.6

    Hello everyone!

    Qt 4.8.6 does not have any Windows 10 support. I understand.
    Can you explain me which internal modifications are developed in order to support Windows 10?
    Are there any issues with memory ? Is there a post on Qt site which indicates that Qt 4.8.6 s incompatible with Windows 10 ?

    Thanks in advance guys!
    CloudCompany

  2. #2
    Join Date
    Sep 2010
    Posts
    17
    Thanked 3 Times in 3 Posts
    Qt products
    Qt4
    Platforms
    MacOS X Unix/X11 Windows

    Default Re: Compatibility Windows 10 - Qt 4.8.6

    Qt 4.8.4 + VisualStudio 2008 + Windows7 (64bits) : it's OK.
    Qt 4.8.4 + VisualStudio 2008 + Windows10 (64bits) : it's OK.
    Windows10 specific support : what do you mean ?

  3. #3
    Join Date
    Dec 2015
    Posts
    7
    Qt products
    Qt4
    Platforms
    Unix/X11 Windows

    Default Re: Compatibility Windows 10 - Qt 4.8.6

    Thanks for your answer.
    I compile my application with MSVC 2010 + Qt 4.8.6, which runs perfectly on Windows 7, but it crashes on Windows 10, on a simple use case.
    That's why I would like to know if Qt 4.8.6 application compiled with Windows 7 can be runnable on a Windows 10.

    If Qt4 application runs well with Windows 10, what means "Full Windows 10 support" on Qt5 apart from Windows 10 specific features (Bluetooth, ...) ?

  4. #4
    Join Date
    Jan 2008
    Location
    Alameda, CA, USA
    Posts
    4,396
    Thanks
    247
    Thanked 691 Times in 681 Posts
    Qt products
    Qt5
    Platforms
    Windows Android

    Default Re: Compatibility Windows 10 - Qt 4.8.6

    If you try to build Qt 4.8 on Windows 10 or use a more recent Visual Studio compiler (MSVC 2013, 2015), you willl get compiler warnings about "unsupported Windows version" or "unsupported compiler version". However, I do not think there is anything in Qt 4.8 that would prevent you from building and using it on Windows 10. There are no pre-built Qt 4.8 versions for Windows 10 - Qt 4.8 was discontinued long before that.

    I suspect that your crash problem is probably due to linking in an incorrect library. Try building one of the Qt example or tutorial programs as a first step instead of devising your own use case test.

Similar Threads

  1. compatibility of qt4.8.2 with qt 5.1.1
    By ntl in forum Qt Programming
    Replies: 2
    Last Post: 28th January 2015, 20:48
  2. Replies: 4
    Last Post: 12th May 2011, 10:06
  3. 64 bit compatibility
    By johnmauer in forum Qt Programming
    Replies: 4
    Last Post: 25th December 2009, 13:28
  4. QtDesigner compatibility
    By lixo1 in forum Qt Tools
    Replies: 2
    Last Post: 11th February 2009, 11:50
  5. VTK and QT compatibility
    By nasty81 in forum Qt Programming
    Replies: 1
    Last Post: 11th April 2008, 12:32

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.