Results 1 to 6 of 6

Thread: problem loading shared libraries

  1. #1
    Join Date
    Jan 2006
    Posts
    976
    Thanks
    53
    Qt products
    Qt3
    Platforms
    Windows

    Default problem loading shared libraries

    Hello,
    under Centos I installed a software, Webots (robotic stuff). When I launch it I got this message:
    Qt Code:
    1. ./webots-bin
    2. ./webots-bin: error while loading shared libraries: libQt5WebSockets.so.5: cannot open shared object file: No such file or directory
    To copy to clipboard, switch view to plain text mode 
    Does anyone can tell me if there is something wrong with my installation of QT, and how get rid of it?

    Regards.
    Regards

  2. #2
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,546 Times in 1,496 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: problem loading shared libraries

    Maybe your centos installation didn't get the package for QWebSockets installed yet?
    Or does the program come with its own Qt libraries?

    Cheers,
    _

  3. #3
    Join Date
    Jan 2006
    Posts
    976
    Thanks
    53
    Qt products
    Qt3
    Platforms
    Windows

    Default Re: problem loading shared libraries

    Sorry I'm a bit novice. What you said doesn't help me. However, it seems Webots comes with its own QT library:
    Qt Code:
    1. [michele@fiordaliso ~/webots/include/qt] # ll
    2. total 32
    3. drwxr-xr-x. 3 4096 Mar 8 16:58 QtConcurrent
    4. drwxr-xr-x. 3 4096 Mar 8 16:58 QtCore
    5. drwxr-xr-x. 3 4096 Mar 8 16:58 QtGui
    6. drwxr-xr-x. 3 4096 Mar 8 16:58 QtNetwork
    7. drwxr-xr-x. 3 4096 Mar 8 16:58 QtOpenGL
    8. drwxr-xr-x. 3 4096 Mar 8 16:58 QtPrintSupport
    9. drwxr-xr-x. 3 4096 Mar 8 16:58 QtWebSockets
    10. drwxr-xr-x. 3 4096 Mar 8 16:58 QtWidgets
    To copy to clipboard, switch view to plain text mode 
    Anyway, I don't know how to proceed....
    Regards

  4. #4
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,546 Times in 1,496 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: problem loading shared libraries

    Is webots-bin a script?
    Does it set the LD_LIBRARY_PATH variable so that it points to the Qt libraries it ships with?

    Cheers,
    _

  5. #5
    Join Date
    Jan 2006
    Posts
    976
    Thanks
    53
    Qt products
    Qt3
    Platforms
    Windows

    Default Re: problem loading shared libraries

    webots-bin is an executable file
    echo $LD_LIBRARY_PATH gives nothing...

    webots-bin is an executable file
    echo $LD_LIBRARY_PATH gives nothing...


    Added after 33 minutes:


    HI again,
    typing this below I get this interesting lines:
    Qt Code:
    1. ldd webots-bin | grep not
    2. ./webots-bin: /lib64/libpng12.so.0: version `PNG12_0' not found (required by /home/michele/webots/lib/libfreeimage.so.3)
    3. libjpeg.so.8 => not found
    4. libjpeg.so.8 => not found
    5. libjpeg.so.8 => not found
    To copy to clipboard, switch view to plain text mode 
    Any suggestion about how solve it? I don't know why but there's no the line about 'QT'......
    Last edited by mickey; 22nd July 2016 at 20:07.
    Regards

  6. #6
    Join Date
    Jan 2006
    Location
    Graz, Austria
    Posts
    8,419
    Thanks
    37
    Thanked 1,546 Times in 1,496 Posts
    Qt products
    Qt3 Qt4 Qt5
    Platforms
    Unix/X11 Windows

    Default Re: problem loading shared libraries

    You should probably check with the orgin/vendor/author of the software.

    Cheers,
    _

Similar Threads

  1. Replies: 3
    Last Post: 24th February 2015, 09:21
  2. error while loading shared libraries
    By RolandHughes in forum General Programming
    Replies: 1
    Last Post: 13th February 2013, 17:26
  3. Shared libraries in Linux
    By Infinity in forum Newbie
    Replies: 7
    Last Post: 13th November 2012, 17:41
  4. Replies: 4
    Last Post: 5th November 2011, 02:38
  5. QProcess on linux - problem with shared libraries
    By michallen in forum Qt Programming
    Replies: 1
    Last Post: 31st October 2010, 10:47

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.