Results 1 to 1 of 1

Thread: Building from source, QWebEngineView missing

  1. #1
    Join Date
    Nov 2016
    Location
    Florida, US
    Posts
    26
    Thanks
    7
    Qt products
    Qt5
    Platforms
    Unix/X11

    Default Re: Building from source, QWebEngineView missing

    I'm going around in circles I think. I wanted to build MuseScore from source (no this is not really about MuseScore), which required a later QT than I had in the distro (at least the Raspberry Pi Ubuntu Mate distro), so I decided to build QT from source, and I keep getting stuck on one aspect.

    Apparently MuseScore requires QWebEngineView (specifically there is an line #include <QWebEngineView>). Slightly older versions required QWebKit (may not have that spelled correctly I no longer have the older version up) but the latest switched, and I see that so did QT.

    So with 5.8 current now, I built it. Strangely no problem, other than a very long time. Built QT Creator so they matched. No problem, it came up, runs, etc. (I have to get some fonts now apparently as I was on 5.5, but I figure I can do that).

    However, no sign of QWebEngineView.

    I've tried lots of variations. I went through the prerequisites carefully and think I have them all.

    Here's my latest:

    Qt Code:
    1. git clone git://code.qt.io/qt/qt5.git
    2.  
    3. git checkout 5.8
    4.  
    5. Init: ./init-repository --module-subset=default,-qtwebkit,-qtwebkit-examples
    6.  
    7. Config: -release -opensource -confirm-license -shared -qt-zlib -qt-libpng -qt-libjpeg -qt-freetype -icu -openssl -qt-xcb -opengl -gui -widgets -skip webkit -nomake examples -nomake tests -prefix /usr
    8.  
    9. make - j3
    10.  
    11. sudo make install
    To copy to clipboard, switch view to plain text mode 

    I got the init from the doc, though it included the webengine, so I dropped that exclusion.

    I've also tried:

    Qt Code:
    1. make -module-qtwebengine
    2. sudo make install -module-qtwebengine
    To copy to clipboard, switch view to plain text mode 

    That does make some additional programs, shows no errors I can find, but still no QWebEngineView. No where, not even in the build or repository directory.

    Now maybe MuseScore's code is wrong (or is this something deprecated?), but in the examples (e.g. here) there's a qtwebengineglobal.h file instead, and I can't find that anywhere in my copy either. So it's not just a MuseScore thing.

    I feel like I'm missing something fundamental here in the clone/init/configure/build process. Maybe the prerequisites.

    All the online instructions I can find that seem fairly current about building seem to advise not to include webengine even ones that show the required packages, so maybe I am simply failing to do the right init statement. I tried a --module-subset=all but had all sorts of compilation errors then in what appeared to be tests or examples (even with the nomake's if I recall, though I am not 100% sure I remember that right). But that I can do a make for module-qtwebengine and have it work makes me think that's not the issue?

    By the way, the ONLY reason I am doing this is I do not see reasonably current QT build for the Raspberry Pi, and so I plan to build it myself. In fact I have built 5.8 there, it seems to work quite nicely for my existing application. But the above description of issues is on Intel 64 bit (in a HyperV VM). Am I correct that no pre-built downloads (offline or online) are provided by qt for the Pi 3B?

    I'll put the configure output in a separate post just to be complete.

    Ok, can't post the config output as text, it's in the attachment in a text file.


    Added after 1 33 minutes:


    Sigh... I just commented out the include file in MuseScore and it actually still builds and runs. No idea what that means, but...

    I guess I don't need to build QT with the Web Engine.

    However, I would still like to know, if someone can point me in the right direction.

    PS. I fixed the fonts by excluding the -qt-freetype and including -fontconfig, so I (think I) am good there also.
    Attached Files Attached Files
    Last edited by Linwood; 26th January 2017 at 02:27.

Similar Threads

  1. Replies: 4
    Last Post: 31st October 2016, 21:23
  2. Building Qt from source with different versions of gcc
    By alexcodercpp in forum Installation and Deployment
    Replies: 0
    Last Post: 9th July 2015, 18:29
  3. Building QT 5.0.1 subset from source
    By bma in forum Installation and Deployment
    Replies: 0
    Last Post: 12th March 2013, 08:16
  4. Missing files when building Qt 4.8 mac against 10.5
    By stal in forum Installation and Deployment
    Replies: 0
    Last Post: 6th February 2012, 05:46
  5. Building qt out of source
    By elizabeth.h1 in forum Installation and Deployment
    Replies: 4
    Last Post: 8th August 2009, 16:56

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.