Results 1 to 1 of 1

Thread: Android build SDK version, target SDK and minimum SDK

  1. #1
    Join Date
    Feb 2011
    Posts
    354
    Thanks
    17
    Thanked 26 Times in 23 Posts
    Qt products
    Qt4 Qt5
    Platforms
    MacOS X Windows

    Default Android build SDK version, target SDK and minimum SDK

    In the build settings of the Qt android project there is the Android build SDK parameter:
    Знімок екрана 2017-02-24 08.49.34.jpg

    I am wondering what should I choose there. For instance, if I select "android-21", does it mean that the application requires API level 21 or higher?


    Android manifest also contains the Minimum required SDK and Target SDK parameters:
    Знімок екрана 2017-02-24 08.49.45.jpg

    Should the minimum required SDK or the target SDK be the same as Build SDK?
    Last edited by mentalmushroom; 24th February 2017 at 07:22.
    Magicians do not exist

Similar Threads

  1. Replies: 0
    Last Post: 17th February 2017, 22:34
  2. Replies: 0
    Last Post: 30th May 2015, 09:45
  3. No rule to make target error while building for Android
    By Awareness in forum Installation and Deployment
    Replies: 1
    Last Post: 23rd December 2013, 02:08
  4. QT minimum build to start developing
    By lurky in forum Installation and Deployment
    Replies: 27
    Last Post: 10th September 2009, 20:42
  5. Which version should I work on i686 host for arm target?
    By sliawati in forum Installation and Deployment
    Replies: 4
    Last Post: 11th August 2006, 09:44

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.