Results 1 to 2 of 2

Thread: Problem with library when i change kit

  1. #1
    Join Date
    Sep 2017
    Posts
    7
    Thanks
    2
    Qt products
    Qt4 Qt5 Qt/Embedded
    Platforms
    Unix/X11 Windows

    Thumbs down Problem with library when i change kit

    Hey guys, so here's the thing:
    I'm cross compiling a web browser made in qt using QtWebKit. I was able to successfully compile/run on my OS (Linux), but when i change to my embedded kit, it gives me an error saying: "QtWebKit/QtWebView: No such file or directory".

    Can i import that library from my other kit? If so, how?

    I have Qt 5.5.1 to my linux and Qt 4.7 to my Embedded.
    Thanks for the attention <3

  2. #2
    Join Date
    Jan 2008
    Location
    Alameda, CA, USA
    Posts
    4,396
    Thanks
    247
    Thanked 691 Times in 681 Posts
    Qt products
    Qt5
    Platforms
    Windows Android

    Default Re: Problem with library when i change kit

    Can i import that library from my other kit?
    No, because it was built for your linux OS, not your embedded OS. Probably the version of Qt you are using for your embedded OS does not have QWebkit built for it by default. You will have to build QWebkit (using your cross-compiler kit, not your linux kit) and install it into the proper place in the embedded Qt hierarchy.
    <=== The Great Pumpkin says ===>
    Please use CODE tags when posting source code so it is more readable. Click "Go Advanced" and then the "#" icon to insert the tags. Paste your code between them.

Similar Threads

  1. Problem using discount library
    By Abdeljalil in forum Qt Programming
    Replies: 6
    Last Post: 3rd November 2014, 17:54
  2. Qwt library building problem
    By Aspirisha in forum Newbie
    Replies: 3
    Last Post: 8th December 2013, 00:10
  3. Ssl library problem
    By zgulser in forum Installation and Deployment
    Replies: 0
    Last Post: 16th April 2012, 11:32
  4. so shared library problem
    By mtrpoland in forum Newbie
    Replies: 3
    Last Post: 13th August 2007, 21:51
  5. shared library problem
    By nhatkhang in forum KDE Forum
    Replies: 9
    Last Post: 28th November 2006, 04:07

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Digia, Qt and their respective logos are trademarks of Digia Plc in Finland and/or other countries worldwide.